[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't mkinitrd on chroot system

On Fri, 2003-06-20 at 16:26, Herbert Xu wrote:
> Ross Boylan <ross@biostat.ucsf.edu> wrote:
> > 
> > I think what's going on is that, because I'm running chroot, /proc is
> > not accessible.
> > 
> > I mention this first, in case it might be relevant to the new
> > installation procedures.  Second, what can I do to get around this
> > problem?
> Is there any problem with mounting proc inside the chroot

Good question!  I may have somehow ended up with an actual directory
named /proc; I got messages that proc wasn't mounted when I tried to
unmount it (after finding nothing beneath it).

I tried mounting it again, and things seemed to work.  So I'm not sure
how I got into this state, but things are OK now.

I just booted into my new Debian system.  This is actually an
intermediary for me to build a custom kernel and set up and EVMS
filesystem.  Back on track.  

Of course, now I have to deal with gcc 3.3 not working to build the
Ross Boylan                                      wk: (415) 502-4031
530 Parnassus Avenue (Library) rm 115-4          ross@biostat.ucsf.edu
Dept of Epidemiology and Biostatistics           hm: (415) 550-1062
University of California, San Francisco
San Francisco, CA 94143-0840

Reply to: