[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

netinst failed to install with bochs

I failed to get the 23 Feb sarge-i386-netinst.iso to install
under Bochs 2.0.2.  This is the upstream version of Bochs,
since I couldn't figure out how to boot from CD in Woody's
Bochs 1.4pre2 packages.

Which package should I file bug reports on for the netinst image?

The first problem I had was getting the slang interface
working.  I don't know if this is even possible yet from the
netinst CD.  It should be the default.  I also noticed
the first screen talked about booting into kernel 2.2.20,
but it actually seems to wind up in 2.4.19.

Things mostly worked through entry 13 of the menu ("install
the base system").  A few menu entries scrolled off the
screen hiding the beginning of the menu.  I just pressed
return, using the default options.  The one exception is I
skipped configuring the network since I haven't yet messed
with Boch's network emulation.  (I know, it's a netinst CD.
But most of the base packages are on it, so a minimal
install seemed possible from it.)

After the base system installed from CD, Bochs paniced with
"cdrom: read_block: read returned -1"; this may be a bug in
Bochs not the installer.  I told Bochs to continue after the
panic, and got back to the installer menu.

All of entries 14-16 (install kernel, LILO, Grub
respectively) failed to work for me -- in each case the
installer tried to get the package by HTTP instead of from
the CD image.  I realize it's a netinst CD and only a weirdo
would try to install from it without the network.  But how
come the rest of the base packages are on it, but not the
kernel and bootloader?


Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more

Reply to: