[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#140579: Report: tftpboot install successfull

Le dim 29/12/2002 à 22:07, Adam DiCarlo a écrit :
> nb <nb@dagami.org> writes:
> > Thanks to Michael R. Schwarzbach and he's post I finally can install
> > debian via tftp. I think the need is going growing to do that and
> > it's really time to update documentation. 
> Can you identify for us exactly what sections in the latest install
> manual are wrong, and which information is completely missing?

This is missing :

1/ different boot methods are not listed (PXE, etherboot/netboot, MBA)
  - I haven't tried PXE. I will in on month (I've bought an openbrick)
  - I haven't tried MBA. I don't even know what it is
  - I have tried etherboot.

  I didn't know before they where so many methods

2/ about etherboot method.
  - one needs first to install mknbi
  - second to download root.bin _and_ tftpboot.img
  - and then use mknbi to add root.bin to tftpboot.img
  - after that tftpboot.img is loadable and usable from a client x86

> I need more help because I don't have an x86 box I can do netbooting
> with.
> Is this bug completely just a documentation issue?  If so, we should
> reassign this as an 'install-doc' bug.

Yes it's only a documentation issue. If you don't know how it works you
can spend much time (24 hours for me and I have many years experience)
or even think it's impossible.

> > I've spent 24 hours to do
> > that and sentences like "NOT YET WRITTEN" are not acceptable today.
> For you to tell us something isn't "acceptable" isn't helpful.  We are
> unpaid volunteers -- saying this sort of stuff just annoys us.  Try to
> stay constructive.  Providing patches or suggested bits of text is
> constructive.

The sentence "NOT YET WRITTEN" was in the documentation.
chapter 4.5.5.

All what aws written about the ip address and the architecture is
completely wrong (I'm talking about x86 plateforme).

I have used the following command to build the loadable and executable
image :

mknbi-linux mknbi-linux
--ip= tftpboot.img
root.bin > tftpboot.img in the /tftpboot directory.

It's like a miracle I was using before :
mknbi-linux --ip=
tftpboot.img > tftpboot.img

the only one difference is in "root.bin" which I have downloaded from
ide-pci 1.44Mb (I don't remember exactly the url).

I have to add that :

a/ I have tried this with etherboot only (I have a 3com 3C905B TX)
b/ I will try PXE method in nearly one month and than tell you how it
c/ I have heard about MBA method but don't know anything else about it.
d/ I didn't try from a sparc (I have a ss10). I'll do that.

I'm very sorry for my poor english.

I you want more informations please let me know.

nb <nb@dagami.org>

Reply to: