[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

net-1440.img test report

I got the sources from cvs (24/11/02, ca. 14:30 CET) and built the
net-1440.img with tollef's build.sh script.

First these 'kmod: failed to exec /sbin/modprobe -s -k net-pf-1, errno = 2'
messages are annoying, but I know that this will be fixed if Herbert Xu
uploads new kernel-image-2.4.19-386-udeb with unix socket support in

Booting on i386 (old Compaq deskpro with Pentium 133 MHz and 172 MB Ram)
Ethernet controller works with 8139too.
Setting up network hardware worked fine (discover doesn't work since
it's for 2.2 kernels and has still the rtl8139 module listed while it's
renamed to 8139too in 2.4 kernels).

Then the default was on Setting up network with dhcp-client while I
wanted to set up a static network. Maybe I would make both to one point
and ask as first question 'static or with dhcp?'.

Finish setting up Debian-Installer worked fine with http ->
net-retriever -> Germany -> ftp.de.debian.org as mirror and no http
proxy entries. I choosed grub-installer and packet modules.
Detecting discs and loading modules worked fine.
Partition a hard disk was also ok, but fdisk is not very user-friendly,
so cfdisk would be much better since it's better known.

make filesystem was ok, but ext3 didn't work, so I took ext2.
Then mounting the hd on /.

Installing base system was no problem, when it's stable all these
'Downloading 234235' messages should be hidden.

Then installing grub was not successful:
Install GRUB on a hard disk:
GRUB needs to install the stage 1 boot loader on a bootable device. This
is usually the fist hard drive. Note that GRUB conuts devices diffently
than the linux kernel, so the fist one is usually '(hd0)'. Leave this at
default if unsure.
[default = (hd0)]>
chroot: cannot execute /sbin/grub-install: No such file or directory
postinst exited with status 256
Debian installer Main Menu

ok, installing lilo (with this annoying default ${bootdev}), giving the
first disc as value worked.

rebooting, network broken (module 8139too not loaded), loaded manually
on tty2, restarted network, wrong gateway ( while I set it to at the beginning (setting up static network).
fixed, then install worked.

While I took sarge at finish setting up d-i, now install-process took
stable after choosing mirror. That also needs to be fixed.

And: at first entry I choosed 'low' for questions, that could be safed
as value for setting up debconf later.

and the questions on old installs to remove ppp and pcmcia packages
weren't there while I would like to have them.

Ah, and if you choose ReadLine at Debconf install, perl-modules should
be installed automaticly, because otherwise there will be problems.

Last memo: many default settings were wrong, but that's ok at this early
status of d-i ;)


Efficiency and progess is ours one more
Now that we have the Neutron bomb
It's nice and quick and clean and gets things done
Kill kill kill kill kill the poor tonight

Reply to: