[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: segfaults with base install

On Tue, Aug 20, 2002 at 08:39:15PM -0400, Adam Henry wrote:
> Greetings,
> First off, I sincerely apologize if this is already covered in a thread--I
> haven't been around here long enough but nothing came up in an archive
> search.  In summary, my problem is with two of the minimal cd installers,
> as well as the full jigdo 3.0 images.  I'm a little stubborn in that
> I don't want to use the floppies just yet.  I would rather help out to
> get this optical process working flawlessly, and offer my trials here as
> debugging wisdom.  Not that any of it is really wise, I would appreciate
> any help to give more precise useful information in the future.  Sorry,
> here are the details:
> 	# /proc/pci
> 	Host bridge: Intel 82439TX
> 	ISA birdge: Intel 82371AB PIIX4 ISA
> 	IDE interface: Intel 82371AB PIIX4
> 	USB Controller: Intel 82371AB PIIX4 USB; IRQ:12
> 	Bridge: Intel 82371AB PIIX4 ACPI
> 	Ethernet controller: Intel 82557; IRQ:10
> 	VGA compat controller: S3 Inc. ViRGE; IRQ:11
> 	# /proc/cpu
> 	Pentium MMX
> 	stepping: 2
> 	MHz: 233.866
> 	f00f_bug: yes
> 	flags: fpu vme de pse tsc msr mce cx8 mmx
> 	# /proc/interrupts
> 	0:	timer
> 	1:	keyboard
> 	2:	cascade
> 	10:	eth0
> 	13:	fpu
> 	14:	ide0
> 	15:	ide1
> 	# /proc/dma
> 	4:	cascade
> It is my intention to later run the system from a ramdisk loaded by cdrom,
> so I am without disk swap.  My hda is partitioned at 650_MB.
> For each of these images downloaded, I verified the md5sum after download
> but before burning, and after burning them I used dd to extract the
> image and re-verify it.
> The problems first turned up when installing the base system over
> the network.  Using different mirrors, here is a list of the different
> errors I have received so far:
> 	# From the alt-f4 vt: "Segmentation fault"    [most frequent
> 	error]
> 	"sh: relocation error: sh: symbol @up2, version GLIBC_2.0 not
> 	defined in file libc.so.6 with link time reference"
> 	"/usr/sbin/debootstrap: /usr/lib/deboo$st'p: not found"
> I know, not very specific.  I tested various mirrors to make sure the
> source of the problem wasn't the network itself, but ultimately tried
> again using Jidgo.  Using the image created by jigdo, here is what I
> see on vt4 when beginning to do the base install:
> 	Segmentation Fault
> 	md5sum: -: Is a directory
> 	rm: /target: is a directory
> 	md5sum: -: Is a directory
> At the same time this happens, here is the corresponding error on vt1:
> 	file:/instmnt/pool/main/g/glibc/libc6_2.2.5-6_i386.deb was corrupt

This same error has been reported previously, 

>From the error messages you saw, it really looks like an obscure 
debootstrap bug, or more likely a corrupted build of debootstrap
within boot-floppies.

One possibility to cause more detailed error messages to appear would
be to add 'debug verbose' to your boot arguments when booting the
installer. I'm not sure if debootstrap listens to that, but quite 

Then, copy this report to a bug on debootstrap.

> And vt2:
> 	(none) user.err dbootstrap[76]:
> 	file:/instmnt/pool/main/g/glibc/libc6_2.2.5-6_i386.deb was corrupt

*------v--------- Installing Debian GNU/Linux 3.0 --------v------*
|      <http://www.debian.org/releases/stable/installmanual>     |
|        debian-imac: <http://debian-imac.sourceforge.net>       |
|            Chris Tillman        tillman@voicetrak.com          |
|                  To Have, Give All to All (ACIM)               |

Reply to: