[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#156710: BOOT error on new install to Mac Performa 6360 PowerPC

On Mon, Aug 19, 2002 at 06:50:31AM -0700, Al Smith wrote:
> > (Read this reply from the bottom up.)
> From the bottom up...
> > It often happens, after a failed boot, that OF is
> > hopelessly hosed.
> > Use reset-all to get a fresh copy.
> > 
> reset-all command issued
> > Here you had quik loaded! I think just changing your
> > boot-file
> > to Linux will let it boot. You can try just typing
> > it in
> > at the boot: prompt.
> > For boot-file, just put the label you use in
> > quik.conf, by 
> > default Linux.
> entered Linux at the boot: prompt - same error CLAIM
> failed
> > You can get a MacOS on a floppy; but I think I read
> > the patch
> > utility doesn't run on your machine anyway.
> > 
> > Yes, even from the installer, you can use nvsetenv.
> > Without
> > arguments it gives you printenv, otherwise it's just
> > like
> > open firmware setenv. So you could make a little
> > shell script 
> > that you could proof then execute.
> > 
> I ran the setenv commands from within the installation
> program, right after the Make System bootable command.
> on reboot, same error: CLAIM failed.
> > 
> > The netbsd page claims that this is a symptom of the
> > wrong 
> > load-base; I don't have any experience with that,
> > but it
> > might be worth a try.
> >  
> [nv]setenv load-base 100000
> was one of the settings I used. The value was from the
> penguinPPC page for this machine. I have also tried
> 600000 as referenced on another page.
> > I would have hoped that would work. 

People don't usually need to change load-base with Debian; 
if you reinstall, do a Cmd-Opt-p-r before your installation
to set the firmware back to defaults.

> I hoped so too. When I saw the quik loading, I thought
> I was all set. I did find another reference online
> regarding two bootable partitions, and the author
> actually edited the partition map to remove a flag.
> His document refered to 'beav' as the editor, but all

It is a binary editor, it probably wouldn't run in the installer
environment. And starting over is probably easier and safer.

> I have from the boot floopy is nano-tiny, which
> doesn't seem to work with his directions. I played
> with the various partitions (hda2...hda7) as
> ATA-Disk@0:# on the boot device, and got CLAIM Failed
> for #'s 2 and 0, all others reported a non-bootable
> partition. I'm wondering of the 'Make System Bootable'

That would indicate your boot block is on 2, and if that's
where your root partition is, that would be right.

> step is adding a second boot flag as suggested by the
> author. (The site is not responding as I write this
> and my notes are at home... sorry I can't reference
> this better...)
>     I'm thinking perhaps I should repartition the
> entire hard disk as a single partition to see if that
> resolves the error. Got any other suggestions...

Yeah, I'm clueless.

*------v--------- Installing Debian GNU/Linux 3.0 --------v------*
|      <http://www.debian.org/releases/stable/installmanual>     |
|        debian-imac: <http://debian-imac.sourceforge.net>       |
|            Chris Tillman        tillman@voicetrak.com          |
|                  To Have, Give All to All (ACIM)               |

Reply to: