[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4 kernel as default boot kernel on CD #1 ??



#include <hallo.h>
Anthony Towns wrote on Fri Apr 05, 2002 um 07:00:08PM:
> On Fri, Apr 05, 2002 at 10:07:38AM +0200, Eduard Bloch wrote:
> > #include <hallo.h>
> > Jim Westveer wrote on Thu Apr 04, 2002 um 05:24:24PM:
> > > > And last, woody ought to be 2.2 based and not 2.4 based ... but since I
> > > > also find it lame to use 2.2.x by default nowadays ...
> > > I disagree,  2.4.x kernels have been out for over 2 years.....we should
> > > not release a "new" version of Debian with such an outdated kernel !
> > > [appologies in advance to the boot-floppy group for all their hard work]
> > Agreed. The decission, which flavor has to be on the first CD, is done
> > by debian-cd's scripts, see
> > /usr/share/debian-cd/tools/boot/woody/boot-i386. CD distributors can
> > change it if they like.
> 
> GUYS, _STOP IT_.
> 
> NOW IS _NOT_ THE TIME TO MAKE CHANGES TO THE WAY THE INSTALL WORKS.
> 
> 2.4 is not the default kernel for woody installs, 2.2 is. Yes, it sucks,

What is _default_? What is _option_? Saying that something is default
implies that you stick to this thing from the installation time until
you install another (optional) thing manually. This is not the case
here. You can completely install and work with bf2.4 unless you decide
to change to optimised 2.4.x kernels or 2.2.x.

> and I don't care. If anyone asks why, blame me. DO NOT MAKE FURTHER
> CHANGES TO THE WAY DEFAULT INSTALLS WORK. Not if it makes a billion more
> people able to use Debian. Not if it's so fundamentally offensive that
> it makes you want to disembowel yourself with a screwdriver.

The problem is, many people download only the first CD and install the
rest from the net. Or they even do not look on other CDs, boot with the
first one and are disappointed (no lang chooser, missing drivers for
various hardware, harddisk controllers, USB keyboards, etc. etc.).

This is not a technical change. It is a political one. debian-cd still
needs at least one release before Woody. IMHO enough time to change.

> debian-cd has exactly one goal right now: make sure we're ready to produce
> official CDs that include the entire archive and let you get started on
> an install.

As said before, I know enough people that run their harddisks on Promise
or Highpoint controllers. With the vanilla flavor, Debian would be
completely useless for them.

Gruss/Regards,
Eduard.
-- 
Ich glaube nicht, daß man dieses Stück in Software umgesetzte Scheiße über-
haupt mieser machen kann, als es sowieso schon ist. Das dürfte das einzige
Programm sein, das vom Verhalten und seinen Anwendern her schlimmer als XP
auf einem Amiga ist. - Manuel Richardt in ka.talk ueber Outlook Express

Attachment: pgp6DiwEOa9Jz.pgp
Description: PGP signature


Reply to: