[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mipsel boot-floppies

* Karsten Merker <karsten@excalibur.cologne.de> [20020216 08:42]:
> > [0] mipsel b-f's are built, but are waiting on someone with a DecStation
> >     5000/120, /125, /133 or /240 to test them to make sure they're not
> Current boot-floppies for mipsel are available for testing at:
> ftp://bolugftp.uni-bonn.de/pub/mipsel-linux/woody-bootfloppies/bf-3.0.19/

I tried the tftpimage-r3k-kn02 image on my DECstation 5000/125.  First
of all, the two problems noted by Flo (see [0]) are still there.  It
should be documented that you might have to add a static address with
arp.  When I booted, I simply got:

    >>boot 3/tftp/tftpboot/tftpimage-r3k-kn02 console=ttyS2 ip=bootp
    2113536?IO: 3/tftp, a.out err (-5)

"/usr/sbin/arp -s <mac-address>" fixed it.

Secondly, it still hangs (or waits a long time) after showing

    DECstation LK keyboard driver v0.04...

I got bored with waiting and plugged in my keyboard but this should
definitely be fixed.  Maciej said he was going to fix by lowering the
timeout, but obviously he hasn't yet.

Then, I get loads of messages that /lib/modules/2.4.17-r3k-kn02/modules.dep
doesn't exist.  While this is just a warning, it's quite irritating
since it's displayed very often.

    kmod: runaway modprobe loop assumed and stopped
    modprobe: modprobe: Can't open dependencies file /lib/modules/2.4.17-r3k-kn02/modules.dep (No such file or dire)
    modprobe: modprobe: Can't open dependencies file /lib/modules/2.4.17-r3k-kn02/modules.dep (No such file or dire)

My biggest problems with dbootstrap was that my cursor keys were not
working properly.  Pressing enter and typing in text (e.g. for the
host name) worked without any problems at all, but cursor up and down
didn't work at all and cursor left and right only sometimes.  This
might be caused by an incorrect miniconf configuration, but I really
don't know.  Apparently you cannot use "j" and "k" to navigate around,
so I stopped since I was only available to choose the first entry in a
menu... has anyone see this while doing an install via serial console?

Finally, although I didn't get that far, I noted that my Debian mirror
(and ftp-master neither) doesn't have a basedebs.tar for mips and mipsel.
Anthony, can you add them?

[0] http://lists.debian.org/debian-mips/2001/debian-mips-200111/msg00095.html

Martin Michlmayr

Reply to: