[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: powerpc install



On Fri, Aug 31, 2001 at 12:20:46AM -0400, Mikhail Kruk wrote:
> http://www.debian.org/releases/potato/powerpc/install.en.html#contents
> 
> In particular:
> http://www.debian.org/releases/potato/powerpc/ch-init-config.en.html#s7.17
> 
> It seems from reading this that the line
> nvsetenv `ofpath /dev/sda2`
> 
> does not apply to NewWorld PowerPC computers. I ssupect that this is not
> the case and in fact it is required for mkofboot install too.

wrong.  

this step only applies to quik, not newworlds.  mkofboot takes care of
setting boot-device correctly for newworld.  

> In any case it is misspelled. It should be
> nvsetenv boot-device `ofpath /dev/sda2`

fixed in CVS for monthes now.

> Now I had the following problem: I did mkofboot (multiple times actually)
> and it never worked. COmputer just wouldn't boot.

you did it wrong most likely.

> So I had to go to OepnFirmware (press Control+Apple+O+F during boot) and
> type in boot hd:yaboot
> Then I did
> setenv boot-device hd:yaboot (in the open firmware) and now computer boots
> just fine.

this is wrong.  please reread the documentation.  the fact that your
completely wrong OF settings work is a miricle.

> So I don't know how much of this was my mistakes and how much was
> inaccuracies in the docs, but at least nvsetenv line is incrrect, that's
> for sure.

you should not have run that command, thats why your machine did not
boot.  

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgpdHZnbuR2Ti.pgp
Description: PGP signature


Reply to: