[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#106218: README boot-floppies SPARC is missing important info

Package: boot-floppies
Version: all

The installation manual at
simply says that booting from floppy is not reliable at all,
but it fails to mention that several Sparcs (e.g. Ultra 10)
have an OBP bug that prevents them from booting
(instead of not supporting booting at all).
Newer Sparcs don't support floppy boot at all, though.

I decided to use floppies on a Sparc 10, since I didn't have
a CD-ROM for Sparc install, and TFTP would have to boot from floppy, too.
Needless to say, I didn't succeed at all.
I can't tell any more what error exactly I got (sorry !), since this machine
is at my uni, and I'm at home now.
After tons and tons of Usenet research via groups.google.com, I finally
found that there was that OBP bug that prevented floppy booting.
Also, this document completely fails to mention *HOW* to boot from floppy
on a Sparc (Stop-A -> OpenBoot: "boot floppy").
I'm *very* unfamiliar with Sparcs. This stuff alone has cost me about an
hour to resolve, and I wasted about 4 hours on the whole problem in total.

The appropriate OBP update can be downloaded as product ID 106121 from
http://sunsolve.sun.com (probably needs some extensive searching, since I've
found Sun's web infrastructure to be a mess).

Note that I haven't tested yet whether it actually fixes the boot problem,
as I couldn't apply the patch via Solaris, since I didn't have the root
password, since this machine was given to us for a quick installfest.
And I didn't have a Solaris boot CD either, for the same reason ;-\
So I tried writing to the UFS via a Linux box in order to remove the root
password, but that killed Solaris, as 2.4.6 UFS write support is *horribly*
broken (not only "DANGEROUS", but BROKEN).
Should have used some sector hex editing instead, that would have worked
perfectly :-\

So, in short, please add the following info to this document:
- how exactly to boot from floppy on Sparcs
- boot bug on several older Sparc Ultras, not possible at all on newer Sparcs,
  OBP update available

I'd have loved to get that machine working at that same day, but unfortunately
it turned out to be way too problematic.
It'll be installed soon, though.

Thank you !

Andreas Mohr                        Stauferstr. 6, D-71272 Renningen, Germany

Reply to: