[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installation impasse

On Sun, Jul 15, 2001 at 01:02:51PM -0700, Andrew Young wrote:
> Thanks for responding.  I'm providing some feedback below:
> > On Sat, Jul 14, 2001 at 04:24:46PM -0700, Andrew T. Young wrote:
> >> I'm trying to migrate from a Slackware system with kernel version 1.2.9 to the
> >> current Debian stable release.  I downloaded the boot, root, and 11 base floppies
> >> for the "compact" version, and all went OK until I got to the part (after
> >> re-booting from the boot floppy) about installing and configuring the rest of the
> >> system, which requires access to the Net.
> >> 
> >> My connection is a PPP link, and it runs through a funny modem that uses port 2f0
> >> and IRQ 2.  On the 1.2.9 system, this is simply configured by setserial in
> >> rc.serial.  But this does not work on the Debian system, which reports "No such
> >> device" although I made the /dev/ttyS14 entry with mknod.
> >> 
> >> It appears that the serial-port code now lives in a module; but where do I find
> >> it?
> > 
> > Most modules are available and installable during the boot-floppies
> > installation process (it's an option in the main menu, look for it).
> > 
> If you are talking about the "load the driver-1.bin diskette" stage, I
> did that.  If you are talking about the "configure the drivers" step
> that comes up when re-booting from the boot floppy, I don't see any
> serial driver offered in those menus (which I believe are presented by
> /sbin/update-modules).

I'm talking about the "Install Operating System Kernel and Modules" and
"Configure Device Driver Modules" steps.

> >> 
> >> It also appears that many other people have had similar problems (mostly while
> >> trying to install Winmodems) -- a search for "debian" and "ttyS14" turns up
> >> hundreds of pages of similar complaints, but no solution.  This is not explained
> >> in either the Serial-HOWTO or the Modem-HOWTO.
> > 
> > What modem are you using ? is it a Lucent or similar ? If you had it running
> > with Slackware/1.2.9 there's  no reason it shouldn't  work with Debian/2.2.19+
> > 
> The modem is a no-name thing that came with my clone -- I can't even find
> a manual for it.  But it has worked OK for about 5 years with the 1.2.9
> kernel.  This is a 486 system, so it is a real hardware modem, not one of
> those imitation things for Windows.
> >> It would be helpful if the installation program provided the means of setting up
> >> this special port for those of us who need it.
> >> 
> >> It would also be helpful if the instructions on how to do this were included in
> >> one of the HOWTO documents.
> >> 
> >> Furthermore, it would be nice if the necessary module (which I suspect is
> >> "generic_serial.o") were readily available from the Debian ftp site.  Apparently
> > 
> > serial.o
> OK -- I'll check on that.  Thanks for the pointer.  I tried extracting
> a copy of "generic_serial.o" from one of the 2.2.19 kernel packages and
> inserting it, but got a message saying there was already a serial
> driver in the kernel -- although lsmod shows nothing -- so I suppose it
> is compiled in.  I tried to create /dev/ttyS14 again with the
> generic_serial module inserted, and got the same "No such device"
> messages as before.
> Nevertheless, I'll try getting a copy of serial.o (which is not listed in
> the menu provided by "update-modules" so far as I can see) and see if that
> works any better.
> Do you know for a fact that /dev/ttyS14 works with the current kernel?

I have used /dev/ttyS14 with my built-in modem succesfully for the last months.
I don't use Debian official kernel package though.

> Has anybody actually checked that this special *configurable* device
> really functions in the current release?  I am beginning to suspect there
> is some incompatibility between setserial or mknod and the current kernel
> for this device which has to be configured entirely after the fact.

Please keep Cc'ing to debian-boot since other people might help you and/or be
interested in your problem. There are people who know better than I too.



Reply to: