[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

BF 2.3.6 install - 2 glitches



(This has been in my postponed box for two days. That "yesterday" I was
talking about was wednesday 13th 19h CEST)

Hi,

I have installed a new system with yesterdays bf cvs. There were two minor
issues.

First, when I tried running the badblocks scan on the new created partitions,
I got the following error:

badblocks: error while loading shared libraries: badblocks: undefined symbol: ext2fs_sync_device

Not really a problem (it wasn't a brand new drive, there had been windos on
it, and I checked (including surface scan) the drive before wiping) (question
is off course if I should trust scandisk ;-)

Second issue, bigger problem: I needed the 3c509 module. Modconf suggested
setting io and irq parameters, so I did (had them ready anyway). This failed
with the error: "invalid parameter parm_io".
I tried a couple of variations (ioaddr, iobase, ...) but nothing worked.
I went to see in the kernel sources on another machine, and lo and behold
there was no io parameter for the 3c509 module indeed. (Granted, it was a
Z.4.5 source, but apparently 2.2 didn't have that parameter as well)
I suppose this could puzzle some other users as well, could this be fixed to
only suggesting to set irq and not io? (Probably this is a modconf bug?)

Regards,

Filip

-- 
It is better to remain silent and be considered a fool, than to speak and
remove all doubt.
	-- Abraham Lincoln

Attachment: pgpYooTtGJN6i.pgp
Description: PGP signature


Reply to: