[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Base Installation (aph 2.3.5 6/7)

On Tue, Jun 12, 2001 at 12:03:27AM -0700, Chris Tillman wrote:
> Shortly after starting the base installation, I got an error in a Warning
> box with only a Continue button. The error was "creating empty ld.so.conf".
> Next was a similar alert "creating empty exim.conf so exim installs OK".

these are not errors, just `informative' messages.  i think they
should just go away myself.  they are actually produced by debootstrap
and not dbootstrap.  

> Just before finishing the base install step, there was a message that
> flashed up out of the blue background, something about "PAM-unix[G4] session
> opened for user man".

known issue, this probably won't go away either.  it happens because
man-db's postinst calls su -c 'mandb -c' and since there is no syslog
listening to /target/dev/log (where the chrooted su ran) the log entry
falls back to being spewed to the console.

> When I looked at tty4 I saw a few problems. I tried to scroll up with
> Shift-PageUp, but that didn't work for me. I looked for a log in /var/log,
> but couldn't find that log; just the one from tty3. So I probably only have
> half the story. Where does that log live? Here are the intereesting
> messages:

this isn't really a log, the stdout/stderr from dpkg are redirected to
/dev/tty4.  shift page up doesn't work after you switch virtual

> After that, I ran Make the Hard disk Bootable, and received the alert
> "yaboot installation failed"
> Switching back to tty3, there were some very informative messages:
> executing yabootconfig -q -t /target -b /dev/hda8 -r /dev/hda13
> <hda8 was swap and hda13 root>

um what?  /dev/hda8 was your swap partititon?  that should not be,
this step should have refused to run if it could not locate your
Apple_Bootstrap partition. please send a dump of your partition table:

mac-fdisk -l /dev/hda

> Sorry you must mount your root and /usr filesystems on /target and
> /target/usr before running yabootconfig
> <I had only designated one partition, no separate /usr partition>

this is because you installed woody and not sid.  yaboot 1.2.1-1.2.1-1
is not in woody yet.  this step will fail until it is.  

the message about mounting / and /usr is from the wrapper on the
ramdisk, this is looking for /target/usr/sbin/yabootconfig which was
added in yaboot 1.2.1-1.2.1-1 which as i said is not in woody.  the
message is generic it says the same thing regardless of how you
partitioned your disk.  if you have a suggestion on how to word that
error better feel free to make it.  don't suggest that it be magical
about figuring out whether mounting /usr would be needed or not, the
idea is you must mount your real installed base partitions.  

> I'll try this on my oldworld as soon as an 8139 driver shows up. (Since i
> can't install from the hard disk anymore, I have to wait for support of my
> network card).

have you filed a bug against kernel-image-2.2.19-pmac yet?  

Ethan Benson

Attachment: pgpklUJIiQMRK.pgp
Description: PGP signature

Reply to: