[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Base Installation (aph 2.3.5 6/7)

Here are errors I noted during installation of the base system and Make the
Hard disk Bootable, on an iMac G3-350. Probably some of these bugs are
already fixed since the build is 4 days old now.

Shortly after starting the base installation, I got an error in a Warning
box with only a Continue button. The error was "creating empty ld.so.conf".
Next was a similar alert "creating empty exim.conf so exim installs OK".

Then I watched it download a bunch of packages and finally set them up. It's
great there is some indication of progress, it goes in alphabetical order so
there's some sense of how long it's going to take.

Just before finishing the base install step, there was a message that
flashed up out of the blue background, something about "PAM-unix[G4] session
opened for user man".

Then I switched over to terminal 3 and 4 to check out error messages. I
could see all the messages on tty3, but there was nothing untoward there
except a plea for donations from the dhcp client.

When I looked at tty4 I saw a few problems. I tried to scroll up with
Shift-PageUp, but that didn't work for me. I looked for a log in /var/log,
but couldn't find that log; just the one from tty3. So I probably only have
half the story. Where does that log live? Here are the intereesting

Setting up console-tools (0.2.3-23)
Looking for keymap to install:

Setting up ifupdown (0.6.4-3)
Automatically converting /etc/network/interfaces failed
<there was a very nice message about how I could reattempt, I did,
and I noted it was trying to create a file in /var/share, which doesn't
exist - probaqbly should be /target/var/share.>

Setting up netbase (4.05)
hostname: Unknown host
Cannot open file "/var/log/exim/mainlog"
<this I believe should also be preceded by /target>

Setting up ppp (2.4.1-1)
Architecture-specific modutils configuration not found, using defaults
depmod: unresolved symbols .../net/3c503.o
depmod: unresolved symbols .../scsi/53c7,8xx.o

Setting up exim (3.2.2-4)
grep: /etc/aliases: not a valid file or directory
<this one didn't exist in /target either>

After that, I ran Make the Hard disk Bootable, and received the alert
"yaboot installation failed"
Switching back to tty3, there were some very informative messages:

executing yabootconfig -q -t /target -b /dev/hda8 -r /dev/hda13
<hda8 was swap and hda13 root>
Sorry you must mount your root and /usr filesystems on /target and
/target/usr before running yabootconfig
<I had only designated one partition, no separate /usr partition>

I'll try this on my oldworld as soon as an 8139 driver shows up. (Since i
can't install from the hard disk anymore, I have to wait for support of my
network card).


Chris Tillman

Reply to: