[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to install `lp' driver in 2.2.

Niccolo Rigacci <niccolo@rigacci.org> writes:

> David Barfoot wrote:
> > 
> > I follow the default options as far as the select drivers,
> > and choose `lp' from the misc menu. The installation always
> > fails with messages beginning:
> > 
> > /lib/modules/2.2.17/misc/lp.o: init_module: Device or resource busy.
> > Hint: this error can be caused by incorrect module parameters
> >       including invalid IO or IRQ parameters.
> I discovered this problem some time ago. It seems that it affects
> boot floppies only (I think it is a busybox problem?), which
> can't properly modprobe le lp module. When installation is done,
> the modules is installed correctly.
> If I remember well the lp.o depends on parport_pc.o, but boot
> floppies modprobe can't resolve this.
> During installation you can load parprot_pc and then lp.
> Beside this, I think that lp.o no longer needs any parameter. The
> help screen presented at installation is builded automatically by
> a script which guesses wrong.

Has all this been resolved?  If not, can someone file a bug against
modconf ?  Seems to be a modconf issue to me....

.....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>

Reply to: