[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with installing debian 2.2

On 26 Sep 2000, Adam Di Carlo wrote:

> Veli-Matti Rautiainen <velraut@st.jyu.fi> writes:
> > > On 23 Sep 2000, Adam Di Carlo wrote:
> > > > there are multiple messages about modprobe failing. Then the installation
> > > > program starts, and I do everything as it suggests. Everything goes
> >    Expect that I forgot to format all the ext2fs partitions during 
> > install. I managed to install it now, the problem was probably due 
> > to the fact that there were not enough free hd space.  
> Even so, you should probably file this as a bug... it should
> recover/detect the condition of running out of disk space.  Do you
> think you could file a wishlist for that?
  Well, I admit that there's something odd with my debian binaries.
  Here's the updated full story...

  Right now I have installed / tried to install it about 12 times. 
  First it was 5 times like I described in my first post. Each time
  I formatted only one / -partition ( 100 MB ) because I didn't pay
  attention. The 6th time I tried to install it, it didn't boot from 
  CD at all, although it was set up to boot from CD in BIOS. 7th and 
  8th time it booted from CD, but right after the installation program
  started, the keyboard was locked, and there was no way to continue.
  9th time it booted, again I formatted only / ( 100 MB ) -partition,
  and the installation went just like it went the first 5 times. 
  Also, the longest time there has been a continuous flow of 
  "kmod: failed to exec /sbin/modprobe -s -k binfmt -0000, errno=8"
  messages is 50 minutes ( checked it out once to be sure that this
  insn't anything normal ).

  10th time I noticed that I hadn't formatted all ext2fs partitions I 
  had available, so now I formatted them all, about 1,4 GB total. Now 
  it did write the LILO in MBR, and I installed the system normally.
  However, there were some ( something like about twenty ) error 
  messages during install, those were about dependencies in some files. 
  Those error messages were pretty much too fast to read, and 
  the system continued to install anyway. I also chose advanced 
  method of selecting packages, and this time, as I was in hurry to 
  get the system up, I didn't install much programs. This was the 
  first time I got the system up at all. However, there was not 
  much installed, so I was not able to do about anything ( I don't 
  know much about linux ). Because there were no X Window system
  so I decided to install it again. 

  11th time was just like 10th, expect that this time I chose 
  simple method of installing packages. I installed all GNOME stuff,
  all language developement, SQL developement, X window system and games.
  I installed about 2/3 - 3/4 of those packages available. This time
  it went OK, but when it started to unpack & install the packages
  ( pretty long session ) it unpacked & installed normally until it 
  got to wwwaffle ( or something like that ) package, and then the 
  system was locked, and there was no way to continue. 

  12th time was like 11th, expect that I thought that the locking up
  was due to the insufficient hd space again ( because I chose so 
  many modules ), so I left out some. This time it installed fine,
  expect that there were still some ( about 20 ) error messages about
  file dependencies. Now I was able to configure X-window system, 
  it detected all my hardware, etc. I got the system up again, but
  when I tried to start the X-window system it said that it doesn't
  support 24 bpp, which I have chosen as a default ( Red Hat 5.1 
  which I used before does support that with the same hardware ).
  So, I changed it to 16 bpp, and then the startx script said, that 
  it doesn't find a mouse, although I configured that during install.              
  So I checked the /dev/ and there were no /dev/mouse, only /dev/usbmouse,
  although I haven't got usb at all in my machine ( that's probably due
  because I configured it wrong ). At this point I can't say much 
  about the system, because I'm completely new to debian and pretty
  new to linux in general, so I can't tell which things are correct 
  and which are not. I was able to play some nethack and compile some
  simple C++ programs.  

  During these installations, I've installed my old Red Hat 5.1 
  many times again, in order to read my e-mail, and get some school
  related stuff done, and it has not shown any problems. One possibility
  is that there would be something wrong with my CDROM, so it doesn't 
  read all the files correctly, but because I get the RH installed 
  easily, I'm not sure about that. However, as a newbie, I can't tell
  if this is a bug or not.

  If you still think I should file a wishlist for this, I can try
  if you tell me what that actually means. I probably can tell 
  pretty accurately, what happened in my machine, and try to repeat
  that error, etc. but not much else.
  One thing I'd like to know is that is it normal, that the installation
  program reports of missing dependencies during install ? If not, what 
  are the possible reasons for that...I think the program should warn
  me in the case I install package X that requires also package Y. 
  And because I'm installing from CDROM, the only other options 
  probably are that there's something wrong with the CD, with my 
  CDROM or with the image the CD was made from ? 

Reply to: