[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#69793: IBM PC Server 320 (MCA/PCI Pentium) cannot boot

Package: boot-floppies
Version: (potato

architecture: i386
model:        IBM PC Server 320
memory:       48MB
scsi:         AIC-7870
cd-rom:       ... it just says IBM CDRM0103 or something like that (SCSI #6)
network card: (yes; dunno exactly)
pcmcia:       N/A
video:        Cirrus Logic GD-54xx VGA
disk:         IBM DFHSS2F 2150 Mb (SCSI #0)
cpu:          single P90 (second processor slot free) [could be P75: see below]

I bought this system second hand (original vintage 1995 circa :-), so
I don't really have any manuals. I've been looking in the BIOS
settings etc to find out as much as possible, but some of this is pure

Apparently the system is MCA but there's PCI too.

The system freezes rather early in the boot process. I'm using the
Potato CD images (tried both disk 1 and 2) downloaded perhaps a week
ago (by a friend -- don't know exactly from where).

I have tried a Debian 2.1 floppy and that one got significantly
farther into the boot process before freezing (with no useful message;
looked like the other MCA incompatible installations I've tried
[OpenBSD install floppy; FreeBSD or something too]). It just stops
doing things and sits there. But I gather that one isn't even supposed
to work on MCA machines.

With the 2.2 CD, booting off the CD, I get a panic-like message which
tells me explicitly how wrong things are. I cannot figure out how to
proceed from here. Any tips would be most valuable.

I have typed in what I could from the screen but there may be typos ...

This was produced with "boot: linux aic7xxx=no_probe". I have tried
without this option, and tried some other options, too; details below.

-------- begin typed-in "screen shot" --------
Page cache hash table entries: 16384 (order 4, 64k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Intel Pentium 75 - 200 stepping 05
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
Intel Pentium with F0 0F bug - workaround enabled.
POSIX conformance testing by UNIFIX
Unable to handle kernel paging request at virtual address 0000daf1
current->tss.cr3 = 00101000, %cr3 = 00101000
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c00fdf84>]
EFLAGS: 0010046
eax: 0000b101   ebx: 0000b101   exc: 00000000   edx: 00000000
esi: 00000000   edi: c02b39f4   ebp: c2ff9f70   esp: c2ff9f70
ds: 0018   es: 0018   ss:0018
Process swapper (pid: 1, process nr: 1, stackpage=c2ff9f70
Stack: 00000000 00000086 c02facda 00000010 c00fdae0 00000000 00000000 00000000
       000fdb2d 00000286 00000f00 c02f7fd4 00000000 c02fae32 00000000 c02fb798
       00000f00 c02f7fd4 c0312e12 00000000 c02f8d4a 00000f00 c02f7fd4 00000000
Call Trace: [<c0106173>] [<c02089b8>]
Code: 2e a0 f1 da 00 00 c4 00 00 00 00 00 87 1c b0 24 a4 b2 90 4b

--------- end typed-in "screen shot" ---------

Specifying the mca-pentium boot option doesn't make any difference.
(The FPU coupling test is skipped, it says "No FDIV bug? Lucky you ..."
but other than that, I see no difference.)

Disabling the hlt check (specifying the option no-hlt) doesn't make
any difference.

Optimistically trying the (made up) option no-posix doesn't affect
anything either :-)

(Incidentally, the screen goes blank after some time and there doesn't
appear to be any way to turn it back on. This didn't happen with the
2.1 floppy.)

I've tried turning off ROM shadowing of the video area at c0000-c7fff
but this didn't matter either.

I looked in the BIOS settings for other stuff which looked relevant
for the error message above but couldn't find anything pertaining to
addresses around 101000 (though there was something around fffff) or

I have other machines available nearby so I can try to run over a
serial console to capture any significant messages before these (but
it's a bit of a hassle for me).

Any hints? I'm not a hardware/kernel person so be gentle ... Thanks!

/* era */

I will gladly trade this monster for something more or less equivalent
that works with U*x-like free operating systems. :-)

The guy who sold it didn't exactly give me a guarantee that it would
work with Linux but I did ask, and I guess I could force him to take
it back ...

The "Pentium 75" is a bit puzzling because while BIOS and the guy who
sold it say it's a 90MHz model, Debian and the tech spec page I found
on IBM's web server say 75MHz. Hmm.

 Too much to say to fit into this .signature anyway: <http://www.iki.fi/era/>
  Fight spam in Europe: <http://www.euro.cauce.org/> * Sign the EU petition

Reply to: