[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

bootfloppies 2.2.11 report

  This is based on the 2000/04/06 images I downloaded from
  http://debian.wave.co.nz/dists/potato/main/disks-i386/ , prepared by
  Mark van Walraven <markv@wave.co.nz> as announced on this list.
  I'll be making separate bug reports where I can to the package listed
  in brackets, but I'm reporting this as a sort of log here first.

I burned a new CDROM last week, and tried again. I made more notes this
time :-)

- The /dev/sr0 - /dev/scd0 confusion is still there. Actually,
  it's gotten worse: the /dev/scd0 device that USED to exist in 2.2.9 is
  now a symlink to sr0 (which doesn't work).  In other words, switching
  to the shell and "ln -s scd0 /dev/sr0" didn't work this time; it gave
  an infinite symlink loop. I had to dig out the major number for scsi
  cdrom and mknod it myself. It's "mknod sr0 b 11 0" in case you're

- The installed system *does* have a /dev/scd0 (it's in base2_2.tgz),
  but still no /dev/sr0 .

- While the dialog (whiptail) screen was displaying "Installing Drivers
  from ...", just before the left bottom corner of the black shadow of
  the text box there is a solitary white on blue "i", undoubtedly from
  some error message or so that's not redirected away. I have no idea
  what it could have been.

- On the "syslog" console, I noticed the following messages at this

  user.debug dbootstrap[30]: umount: Device or resource busy
  user.info dbootstrap[30]: depmod: *** Unresolved symbols in /lib/modules/2.2.14/pcmcia/3c575_cb.o
  [... plenty of these, apparently covered by bug#62100 and/or bug#61544]

  These depmod errors were generated while "detecting modules, please
  wait" was displayed, which sounds reasonable.
 *The interesting thing about these depmod errors was that only every
  other line was reported! (as compared to what was displayed during the
  reboot).  This makes one wonder if perhaps the busybox syslog function
  only logs every other line!
  [boot-floppies, at least the syslog stuff]

- I discovered the following problem while reproducing the previous one:
  Choose "configure device driver modules", switch to tty3 (syslog
  output) immediately, and then the modconf output appears on tty3,
  overwriting all the syslog messages. Unfortunately the input is still
  coming from tty1, which was most confusing at first. There's some
  redirection problem here (either too much or too little).

- In "Timezone Configuration", I has just chosen what the local timezone
  is. Then the next screen says:
    The hardware clock says the time is now
        Fri Apr  7 14:30;12 2000
  Having this also displayed according to the TZ I had just configured
  would be nice, I could then more easily say whether the hardware clock
  is indeed running on UTC or not. I happen to know that local time is
  currently +2 hours compared to UTC, and hence the displayed time
  should be -2 hours in relation to local time. However, I assume many
  users won't, and will be confused by that screen.

- Why "Updating locate database" during the first boot from the
  harddisk? This introduces an unnecessary delay before the rest of the
  install can be completed, and is pretty useless as well, as plenty of
  stuff is going to installed additionally; also, in most cases, the
  PCMCIA stuff will get removed almost immedialtely. Do it at the end
  (preferably in the background). In fact, in my case anacron got
  installed and promptly began doing it (amongst other things of course).

- Because of the PCMCIA module problems (at least, I think that's the
  reason), the install thinks I don't need the PCMCIA modules and offers
  to remove the modules etc. However, although it's not a laptop, it
  *does* have PCMCIA slots (it's an Digital pentium Multia, looks very
  similar to the Alpha Multia a.k.a. UDB).
  [none, awaiting fixed pcmcia modules]

- The example name for the cdrom (while "apt-cdrom add" is running) is
  "Debian 2.1r1 Disk 1", which is pretty wrong for potato.

- After "apt-cdrom add" has run (in plain text mode), the procedure
  switched back to dialog mode (whiptail?), and shows the "Apt
  Configuration" screen, with "Choose what method apt should use to
  access the Debian archive:" . I choose "cdrom", and then "apt-cdrom
  add" is run again :-(.  Apparently one must choose the <Cancel> button
  in the "Apt Configuration" screen to continue, which isn't quite
  intuitive: I want to continue with the installation, not cancel it!
  The fact that I'm cancelling out of a sub-procedure is not apparent to
  the user; to the user the entire installation looks like one big
  procedure which must NOT be cancelled!

- When choosing the tasks, I chose:
    * Dialup ISDN (which includes diald and dialdcost, which is wrong)
    * Gnome Apps
    * Gnome Desktop (which doesn't include a gnome window manager?!)
    * Gnome Net
    * X Window System
  Here I must this time choose <Quit>.  Note that above I needed to
  choose <Cancel>; a constant user interface seems very difficult :-(
  Same thing with "cdrom", "CDROM", "CD-ROM", "debian" and "Debian";
  there are more examples of this inconsistency. Also, many things are
  capitalized unnecessarily, such as "Installing Drivers from...",
  "Media Change" (see next item).
  [tasksel] [the inconsistency thing: ??]

- After choosing <Quit> above, it continues :-)
  It says:
    Media Change: Please insert the disc labeled 'foo' in the
    drive as '/cdrom/' and press enter
  I'm wondering what use the "as '/cdrom/'" is here...
  Here the cdrom doesn't get mounted. The /dev/cdrom symlink points to
  /dev/sr0 which (surprise) doesn't exist. I had to manually fix this.
  The surprising thing here is that apt-cdrom didn't have any trouble
  mounting it...

- The following text appears:
    Scanning packages...
    Use of uninitialized value [...]
  I couldn't see the rest of this (perl) warning because it got
  overwritten by the debconf dialog screen.  Perhaps the -w flag should
  be removed in the final release of ALL perl scripts.

- The installation finished off with:
    Do you want to erase the downloaded .deb files? [Y/n]
    Press enter to continue.

    Debian GNU/Linux 2.2 (frozen) boxname tty1
    boxname login:

  Firstly, can't it check that there is nothing downloaded? I half
  expected it to try deleting files from the cdrom.
  Note the lack of the "Have fun!" message...

- The MOTD says to look at /usr/doc/*/copyright for copyright info,
  shouldn't that be /usr/share/doc/*/copyright by now, so that people
  get used to it?

That's about it for now. I'll wait a day for any comments and then start
checking the BTS and reporting bugs if not yet there.

Paul Slootman
home:       paul@wurtel.demon.nl http://www.wurtel.demon.nl/
work:       paul@murphy.nl       http://www.murphy.nl/
debian:     paul@debian.org      http://www.debian.org/
isdn4linux: paul@isdn4linux.de   http://www.isdn4linux.de/

Reply to: