[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Successful 2.2.6 installation using dhcp+pcmcia


I've just installed the 2.2.6 boot floppies from lully onto my
Thinkpad 570.  I did it from floppies (all 15 of them), and then used
a Linksys cardbus 10/100 ethernet card and a dhcp connection to
download the rest.  I had no problems with the floppy images.  Now
that I know what to do, it seems easy.

The biggest problem that I ran into was getting PCMCIA to work.
Apparently, cardmgr couldn't find the modules, so it couldn't really
start.  Looking at the error messages on the virtual terminal, it
seemed to want to look in /lib/modules/2.2.14 rather than
/target/lib/modules/2.2.14.  There weren't any modules in
/target/lib/modules/2.2.14 anyway, though.

To get it to work, I downloaded the deb for pcmcia-modules onto a
floppy and loaded that after the initial reboot, during apt
configuration.  I configured /etc/pcmcia/network.opts to use PUMP, and
then the network was set up automagically when I inserted the card.

I tried a similar thing with slink boot-floppies (I was going to
manually load in a dhcp client).  The slink floppies don't have
pcmcia-modules either, but card-mgr didn't give any errors.  I never
could get card-mgr to recognize the card (it knew it was there, but it
couldn't figure it out), even though it is listed as supported in the
slink version of pcmcia-cs.

Then I downloaded 233MB of packages, which worked mostly fine.  It
installed a bunch of packages, and then stopped, saying it had
problems configuring certain packages: smail, anacron, and
task-laptop.  I ran

apt-get install anacron

It installed a bunch more packages, and then it stopped again, saying
that it had problems with smail, mailx, and something else I can't
remember.  I then ran

apt-get install smail

and it seemed to complete the installation.  My guess is that these
packages needed other packages to be installed before they could be
installed.  The order was a little messed up, so that's why I could
install it manually.

After it seemed to have finished, I ran dselect, and there were a lot
of packages left over, which I installed.  There was one problem,
though, with kernel-package-2.2.14.  dselect wanted to install that,
but it gave me lots of warnings about the modules, etc.  Running
apt-get update and apt-get upgrade didn't do anything (i.e. it didn't
think that kernel-package-2.2.14 needed to be installed).

I had a problem with dependency problems between groff and jgroff
which prevented installing man-db.  jgroff both provides and conflicts
with groff.  I think I just ran into bug #39958.

I also had the keymap problem (azerty instead if qwerty), but that
only messed up the console, and not X.

Overall, it was not as painful as I expected.  As I mentioned, fixing
the pcmcia problem was pretty easy, and I didn't run into any dhcp
problems.  In fact, I was quite impressed by how easy it seemed, and
I'm really grateful to the boot-floppies team.

Walter Landry

Reply to: