[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Report on 2.2.5 boot-floppies

Compaq DeskPro using DHCP and 2.2.5 compact 1.4MB disks.

Not a big success - took three tries and manual intervention to achieve
a full install. DHCP works though, but alas not perfectly.

Error message of the week:

Do you want to make the VGA16 X server the default? (y/n) [y] n
'n' not understood.  Using default of 'y'.

I'll raise separate bugs for the smaller items, but there were some
major problems.

Attempt 1: Install boot and base from DOS partition on HD. Kernel
installs OK, but system hangs when trying to install base. Can switch
consoles but pressing return does not activate shell. Last messages:
kern.info cdrom: open failed       (and yet I didn't mention the CDROM
at all)
kern.debug VFS Disk change detected on device ide1(22,0)
Rebooted and tried again.

Attempt 2: boot on floppies, base via NFS. Gave NFS location as
mirror:/var/spool/mirror/debian as per example but was then asked for
the subdirectory. When I put . was told no dists subdirs present and was
given list of all directories in root. Cancelled and tried again giving
just mirror:/var/spool/mirror as location. System hangs and have to

Attempt 3: boot on floppies, base on DOS partition. Installs OK - no

After installing, I was able to happily mount my NFS server (another
Debian potato box) and install packages from it, and I've never had this
sort of problem with installations before.

Other problems: /dev/hda3 not cleanly unmounted message on first boot,
requiring fsck.

DHCP not started after boot - had to start manually.

Unable to successfully configure to install packages via apt using
whiptail-based configuration. If I tried NFS, it doesn't give me
anywhere to enter the server, only a pathname. If I use HTTP, it just
hangs. If I use file, it works fine but refuses to complete because I
don't have a copy of sources! Finally I edited /etc/apt/sources.list by
hand, and no further problems.

I'm now writing this using Netscape on the newly-installed system, so
it's possible to get round all this.

Ian Redfern.

Reply to: