[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[install report] 2.2.4-2000-01-03 (en) (A ToDo list)

 Now that I've got VMware (http://www.vmware.com) working, I can run
 through the install a few times and send a little feedback.
 (breeee!) <-- a little feedback.

 One thing I noticed is that when syslinux is up, and the help screens
 are displayed, my gkrellm CPU meter sits at 100%, but after the Linux
 kernel boots in the virtual machine, the CPU meter goes way down to a
 respectable level.  Q: Could `syslinux' be made to HLT the CPU when
 it's idle, like Linux does?  How hard would it be to do that, for
 someone who understands it, I wonder?

 The help screens look pretty good, but the Copyright ought to say
 "2000" rather than "1999".  A quick grep shows a lot of places where
 that probably should be done.  The other thing with the <f10> screen
 is that it says the copyrights for software can be found in /usr/doc,
 but it should say they are in /usr/share/doc.

 I think that the "Pre-2.2 Linux Kernel Compatibility?" ought to
 default to <No> rather than <Yes>.

 I had trouble, also with `debconf', knowing whether the active button
 is the blue one or the red one.  Other than that the cursor sits by
 the active one, there isn't much indication...  (nitpick?)

 When it went black to run `mke2fs' on the hard drive partition, it
 stair-stepped.  The terminal modes ought to be explicitly set then to
 prevent it.

 I was unable to reproduce the bug I mentioned where I'd switched vt's
 and it redisplayed on the current vt, rather than on vt1.  This is
 the same rescue set I used then too.  I'll keep trying...  maybe
 there's a specific place in there where it can happen, but can't
 happen most times?

 `netfetch' is pretty useless for installing the OS and modules,
 since, even though it will allow you to configure the network, (say
 something useful here) there is not a driver for the network card
 installed, as far as I can tell.

 In the paragraph printed by `emacs' and `vi', "you may" is hanging off the right
 edge of the rest of the paragraph.  It should be reformatted.

 The /i386 directory is owned by group 1001, rather than `root'.

 After installing the driver disks from floppy, when I pressed Enter
 over "Configure Driver Modules", a message printed at the bottom of
 the screen that said: "depmod: Error reading ELF header: no such file
 or directory".

 As was mentioned previously by someone on the list, not all of the
 driver modules have description strings.  They should all have them;
 it will look much more professional then.  I have yet to see
 parameter documentation for any of them.  That needs to be done also.

 After I inserted the module for `pcnet32' (the device that VMware
 pretends to have), when it went black and messaged about "installing
 the driver...", the line at the top of the screen is too long and
 wraps in the middle of a word.  The error/success (in this case
 success) message printed with the first character right below and one
 char to the right of the period in the first line; that is, it
 stair-stepped.  The terminal settings are not right again.

 At that point, vt1 is hung.  I can switch vt's with Alt-Fkey, and can
 see the message on vt3 printed by the driver.  It appears to have
 insmod'ed correctly.  Nothing happens when I press Enter on vt1 now.
 Issuing a `kill' to the PID of the shell running `insmod' brought it
 back to the `modconf' screen again, but it won't take keyboard input.
 I can switch vt's and the keys work fine on vt2; I can run shell
 commands, but vt1 is dead in the water... Ok, I looked at `ps' agian,
 and killed the `modconf'.  Now `dbootstrap' is back and takes
 keyboard input again.

 I tried to run "Configure Device Driver Modules" again, and this time
 installed `nfs'.  It did the same thing.  `lsmod' shows that both
 drivers got installed.  One of the processes hanging around was a `sh
 -c depmod [args]'.  Could that be what's hanging it?

 I had the VMware ethernet configured incorrectly, and had to halt and
 power it off, then reconfigure it for `host only' networking.  (My
 kernel doesn't have eth aliases configured in, for the VMware bridged
 ethernet device.)  When I rebooted the rescue set, after I remounted
 the swap and /, I ran a `lsmod' to see if the modules got put back
 like I had them.  They had not been.  I selected the option to do
 that, and got the error mentioned previously, with another saying
 something like "dbootstrap: ??? not found".  `modconf' would not
 start.  Running `insmod pcnet32' worked, and I was able to "Configure
 the Network" and can ping www.debian.org.

 Choosing `netfetch' and taking the defaults returned an HTTP/1.1 404
 error.  (Reminds me of the time I tried to net-install Red Hat once a
 long time ago.  Wonder if they got theirs working?)  I changed the
 URL, inserting "debian/" after the hostname portion of the URL, and
 it worked... but got partway through the download and suddenly I was
 back at the main `dbootstrap' screen again.  It looks like part of
 the base is installed, but not all of it.  Is the base it's bringing
 down not all there, or did `dbootstrap' seg fault or something?  I
 didn't see any error messages; but perhaps it printed something and
 that got overwritten too quickly for me to see.

 I will try again when 2.2.5 is ready.

Reply to: