[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

FWD: Re: Problem about debconf on potato

Package: perl-5.005-base
Version: 5.005.03-5
Severity: important

FileHandle needs IO::File. This is just as crippling a problem for debconf
and the base system as was the overload omission.

----- Forwarded message from Olivier Lemaire <sholari@online.fr> -----

Date: Thu, 13 Jan 2000 03:58:30 +0100
From: Olivier Lemaire <sholari@online.fr>
Organization: Fumble.org
X-Mailer: Mozilla 4.5 [en] (X11; I; Linux 2.2.12 i686)
To: Joey Hess <joey@kitenet.net>
Subject: Re: Problem about debconf on potato

Joey Hess wrote:
> This problem is fixed in the version of perl that was just installed into
> debian today. Upgrade.

I've upgrade to 
and eventually too :

and re-installed debconf, crossing my toes... and :
olivier@launtra:/usr/bin$ sudo apt-get install debconf
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/122kB of archives. After unpacking 355kB will be used.
Selecting previously deselected package debconf.
(Reading database ... 15473 files and directories currently installed.)
Unpacking debconf (from .../debconf_0.2.71_all.deb) ...
Setting up debconf (0.2.71) ...
Can't locate IO/File.pm in @INC (@INC contains:
/usr/lib/perl5/5.005/i386-linux /usr/lib/perl5/5.005
/usr/local/lib/site_perl/i386-linux /usr/local/lib/site_perl
/usr/lib/perl5 .) at /usr/lib/perl5/5.005/FileHandle.pm line 9.
BEGIN failed--compilation aborted at
/usr/lib/perl5/Debian/DebConf/ConfModule.pm line 32.
BEGIN failed--compilation aborted at
/usr/lib/perl5/Debian/DebConf/AutoSelect.pm line 19.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line
dpkg: error processing debconf (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
E: Sub-process returned an error code (1)

...and seems to be others modules now.... 
Are u sure about Perl package version ?
> Olivier Lemaire wrote:
> > Greetings,
> >       It seems overload.pm is not included in my perl (5.005.03-4.1 deb) ! So
> > why does debconf don't require it, and should debconf start de perl
> > installation module of overload.pm if so (I does'nt know how to do this
> > right now, but I'me gonna read a little more perl doc about it :)
> >
> > Olivier <sholari> Lemaire.
> --
> see shy jo

see you from france :)

----- End forwarded message -----

see shy jo

Reply to: