[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#53563: Retracting original bug, adding new ones with lower severity

Ross Boylan <RossBoylan@stanfordalumni.org> writes:

> Using the latest (2.2.3) boot-floppies, I can not recreate the original
> bug.  Almost certainly I was using 2.2.2, or some defective mix of
> products, when I ran into the problem.

> So I withdraw the bug report, as far as it concerned the path names being
> all screwed up. I do not consider the remaining bugs critical, since I was
> able to get a basic installation running.

Ok -- i'm closing the bug.

Please please please reopen the bugs below on the packages I indicate
in my comments.  I really thank you for the detailed efforts and
testing you have put into all this.  By filing bugs as indicated
below, you will help immeasurably in improving the quality of Debian.

> The reported problems with mv, cp, and mounting vfat still stand, though I
> understand some of them have already been cleaned up.

Yes -- will be fixed in 2.2.4.  No need to file bug.

> By pushing things along I ran into some more errors, some of which may
> reflect bugs in the boot floppy setup or the packages it depends on.  This
> report is quick and dirty, in hopes it will provide clues for areas that
> need work.
> 1) ae ^N fails (minor bug)
> When editing a file with long lines (it was on a vfat volume) with ae, I
> found that ^n would only move me to the end of the current screen line.
> Hitting it repeatedly did not move me down more lines.

Please file a bug on the pkg 'ae'.

> 2) Can't access root account
> When I got to my first run through dselect I wanted to mount some
> additional partitions.  I discovered that I got "authentication failures"
> when trying to su to root from another console, logged in as the new
> regular user I had just created.  I think I was unable to login as root
> also, but I'm not sure.  Later in the install, I could su or login at will.

Wow -- we're going to need to look into this more.  Anyone have a
clue?  Is it a PAM problem?  Possibly fixed already?

> 3) mkdir from busybox doesn't stick
> I created some directories and mounted partitions to them shortly after
> loading modules (e.g., vfat, ntfs).  But later, using the regular shell,
> there was no sign of them.

Woah -- Erik?  You can file a bug against boot-floppies for this, or
let Erik just pick it up.

> 4) ppp setup fails ("feature"?)
> I got the error 
>   /usr/sbin/ppds in file /etc/ppp/peers/provider unrecognized option
> /dev/modem
> I later realized I used a real name, instead of "provider" when prompted.
> I ran pppconfig and created a provider entry, and thiings worked.  I don't
> know if this accounts for the error.

File a bug on pppconfig I think.

> 5) apt-get may overwrite its initial file (grave, if true) Via
> dselect I tried to edit the entries in apt-get.  Though I thought I
> was simply adding to the sources it used, I later noticed the
> sources.list had only entries which I had made.  Since I also used
> ae on the file, and since I might have misread the messages about
> what the configuration was doing, this might not be an error.

File a bug against apt.

> 6) Can't write to NTFS (probable known limitation) I attempted to
> download to an NTFS partition, and couldn't write to it.  I'm
> reporting this just in case the ntfs driver is supposed to handle
> writes.  The reading worked very nicely (except apt-get gave an
> error about the MFT when looking for packages on NTFS drives).

Yeah -- that's a kernel issue -- not much we can do....

> I'm currently mucking around with the portion of the archive I
> downloaded, apt, and the packages I may have accidentally selected
> while using dsselect earlier. 

Odd.  I'm not sure what you're saying. 'apt' is in base, so why did
you have to reinstall it?

> I have a bunch of broken packages
> (code C), according to deselect, including required ones (!).
> However, the scenario I'm playing may be fairly typical: I tried
> downloading packages I thought I would be likely to need, and then
> installed debian.  I now want to install some of those packages.

Yes -- it can be hard to attribute such problems to pkgs, but if you
are able to, please file bugs for them.

> As it stands, the install process remains intimidating, requiring
> detailed knowledge of hardware and of Linux (e.g., what modules do I
> need to load).  While this is unfortunate, it is not a bug.

Yes, it's true.  My stress is on maximal flexibility and maximal
supported hardware versus ease of use.  We are hoping to add the
apt-configurator for automated (in some cases) apt configuration, as
well as the tasksel system, which allows you to skip dselect (or not,
as you prefer). Also, the xviddetect program, anXious, will help with
the selection X packages, a big FAQ.

I realize that potato installation will be an *incremental*
improvement over slink, rather than a radical improvement.  C'est la
vie.  For potato, at least, it will still be up to the commericial
Debian repackagers (Corel, Storm) to provide the easy GUI system.

.....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>

Reply to: