[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#53563: marked as done (File name confusion prevents install from hd)

Your message dated 02 Jan 2000 14:23:17 -0500
with message-id <oa1z80ffbu.fsf@frijole.fake>
and subject line File name confusion prevents install from hd
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Darren Benham
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 27 Dec 1999 23:11:57 +0000
Received: (qmail 8485 invoked from network); 27 Dec 1999 23:11:57 -0000
Received: from smtp7.atl.mindspring.net (
  by master.debian.org with SMTP; 27 Dec 1999 23:11:57 -0000
Received: from wheat (user-33qth3f.dialup.mindspring.com [])
	by smtp7.atl.mindspring.net (8.9.3/8.8.5) with SMTP id SAA03010
	for <submit@bugs.debian.org>; Mon, 27 Dec 1999 18:11:50 -0500 (EST)
Message-Id: <>
X-Sender: rboylan@pop.mindspring.com
X-Mailer: QUALCOMM Windows Eudora Light Version 3.0.5 (32)
Date: Mon, 27 Dec 1999 15:07:59 -0800
To: submit@bugs.debian.org
From: Ross Boylan <RossBoylan@stanfordalumni.org>
Subject: File name confusion prevents install from hd
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"

package: boot-floppies
version: 12/20/99 unstable
severity: critical

I was completely unable to do a hd-based install because the installer kept
looking files with different names from the ones I downloaded.  E.g., on
the archive, disks-1.44/rescue.bin.  But the installer wants

I tried renaming the files, but could never get the install to work.
First, the file name behavior was poor.
I would mkdir disks-1440 and it would appear in listings as disks-14.  But
if I cd disks-1440, it works.
(By the way, mv doesn't do whole directories; if that's not supposed to be
a limitation of the shell it would be good to fix).

I tried booting to NT and renaming the files with the right names (the
partition is fat).  When I go back to Linux install, files show up with
names like disks-~1 (this happens to files as well as directories; I'm just
trying to give a flavor)--in other words, the short form of the DOS names.

When, through the process of renaming and copying described 2 paragraphs
above (i.e., under the linux install environment, running a second console)
I was able to get past the complaints about the names, I got an error
message "Unable to extract floppy image from rescue.bin" (very approximate,
from memory).  After inspecting the files, I see they have different
lengths from the archive--perhaps the drive was mounted in some mode where
the mv/cp commands were doing cr/lf conversions?

In short, there seem to be at least two problems here:
1) the names the install process is looking for do not match the names in
the archive
2) the handling of long file names from a vfat partition is poor.

The final failure might indicate another problem....

The partition I attempted to use was a logical partition, formatted FAT by
NT 4.0, SP4.
I tried using it from the /dev/hda2 choice on the install dialogs, and also
by mounting it.
mount -t vfat failed.
Received: (at 53563-done) by bugs.debian.org; 2 Jan 2000 19:23:37 +0000
Received: (qmail 19675 invoked from network); 2 Jan 2000 19:23:36 -0000
Received: from 209-122-221-165.s546.tnt4.nyw.ny.dialup.rcn.com (HELO frijole.fake) (@
  by master.debian.org with SMTP; 2 Jan 2000 19:23:36 -0000
Received: by frijole.fake (Postfix, from userid 421)
	id 42ECB2190D; Sun,  2 Jan 2000 14:23:17 -0500 (EST)
Sender: apharris@frijole.fake
To: 53563-done@bugs.debian.org
Subject: File name confusion prevents install from hd
From: Adam Di Carlo <adam@onshore.com>
Date: 02 Jan 2000 14:23:17 -0500
Message-ID: <oa1z80ffbu.fsf@frijole.fake>
Lines: 5
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii

Closing bug, user confirms was closed in 2.2.3.

.....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>

Reply to: