[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#53563: File name confusion prevents install from hd

package: boot-floppies
version: 12/20/99
severity: critical

I was completely unable to do a hd-based install because the installer kept
looking files with different names from the ones I downloaded.  E.g., on
the archive, disks-1.44/rescue.bin.  But the installer wants

I tried renaming the files, but could never get the install to work.
First, the file name behavior was poor.
I would mkdir disks-1440 and it would appear in listings as disks-14.  But
if I cd disks-1440, it works.
(By the way, mv doesn't do whole directories; if that's not supposed to be
a limitation of the shell it would be good to fix).

I tried booting to NT and renaming the files with the right names (the
partition is fat).  When I go back to Linux install, files show up with
names like disks-~1 (this happens to files as well as directories; I'm just
trying to give a flavor)--in other words, the short form of the DOS names.

When, through the process of renaming and copying described 2 paragraphs
above (i.e., under the linux install environment, running a second console)
I was able to get past the complaints about the names, I got an error
message "Unable to extract floppy image from rescue.bin" (very approximate,
from memory).  After inspecting the files, I see they have different
lengths from the archive--perhaps the drive was mounted in some mode where
the mv/cp commands were doing cr/lf conversions?

In short, there seem to be at least two problems here:
1) the names the install process is looking for do not match the names in
the archive
2) the handling of long file names from a vfat partition is poor.

The final failure might indicate another problem....

The partition I attempted to use was a logical partition, formatted FAT by
NT 4.0, SP4.
I tried using it from the /dev/hda2 choice on the install dialogs, and also
by mounting it.
mount -t vfat failed.

Reply to: