[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Status of Slink

Enrique Zanardi wrote:
> On Mon, Dec 07, 1998 at 09:53:04PM +0100, Martin Schulze wrote:
> > Brandon Mitchell wrote:
> > > Boot floppies:
> > >   At last check, the drivers disk was giving problems.
> > 
> > Last check is that they don't work properly:
> > 
> > *** Topic for #Debian.DE: boot-floppies 2.1.2 sind etwas weniger buggy ;)
> > 
> >                                         [ ... are little less buggy ]
> May someone tell me where do they fail? I've seen a few reports of
> succesful installs using 2.1.2, but no unsuccesful ones yet. It's hard to
> fix bugs you don't know about... :-(

OK, you asked for it! :-)

First, let me say I only downloaded the 2.1.2 deb and built the disks
myself so they may not be perfect.

1) There is a missing dependency on dosfstools. The build failed when it
didn't find mkdosfs.

2) The install from "hard disk" option doesn't work. The installation
program loops back to the opening "mono" screen everytime. I was able to
work around problem by opening another console and manually mounting the
dos partition then selecting the "already mounted" option.

3) You haven't created enough /dev/hd?? devices!! The base system contains
only /dev/hda1 -> dev/hda8 and /dev/hdb1 -> /dev/hdb8. My system has lots
of partitions (up to /dev/hdb16!!). The hamm disks go up to /dev/hda20.
Furthermore, there is no /dev/hdc or /dev/hdd at all.

4) Struck a bizarre problem with the "install.bat". When I ran the
install.bat from dos, the kernel started to load then exited with an error
message "cannot open image file for initrd" or something to that effect.
Yet, when I ran loadlin from the dos command line with the exact same
syntax as in the bat file, it worked. This problem could be related to my
dodgey build. Will investigate further.


Reply to: