[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Status of Slink

On Wed, Dec 09, 1998 at 12:07:59AM +1100, Greg Schafer wrote:
> OK, you asked for it! :-)
> First, let me say I only downloaded the 2.1.2 deb and built the disks
> myself so they may not be perfect.
> 1) There is a missing dependency on dosfstools. The build failed when it
> didn't find mkdosfs.

As that is arch-dependent, and boot-floppies is a binary-all package,
there's not much I can do about it. Also, it's sort of a "source
dependency". Our pkg system is not good enough for this "source packages".
> 2) The install from "hard disk" option doesn't work. The installation
> program loops back to the opening "mono" screen everytime. I was able to
> work around problem by opening another console and manually mounting the
> dos partition then selecting the "already mounted" option.

Weird. I've tested the "hard disk" option myself, and it worked
> 3) You haven't created enough /dev/hd?? devices!! The base system contains
> only /dev/hda1 -> dev/hda8 and /dev/hdb1 -> /dev/hdb8. My system has lots
> of partitions (up to /dev/hdb16!!). The hamm disks go up to /dev/hda20.

That's a makedev*.deb bug: 


                major=`Major ide0` || major=`Major hd 3` || continue
                unit=`suffix $arg hd`
                base=`index ab $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
                for part in 1 2 3 4 5 6 7 8 # 9 10 11 12 13 14 15 16 17 18 19 20
See this one? ..............................^
                        makedev hd$unit$part b $major `math $base + $part` $disk

May you report it to the BTS, please?

> Furthermore, there is no /dev/hdc or /dev/hdd at all.

Another one for makedev*.deb


                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
                $0 $opts hda hdb
                $0 $opts xda xdb
                $0 $opts sda sdb
                $0 $opts pty
                $0 $opts console
                $0 $opts ttyS0 ttyS1 ttyS2 ttyS3
                $0 $opts busmice
                $0 $opts lp
                $0 $opts par

No hdc or hdd.

> 4) Struck a bizarre problem with the "install.bat". When I ran the
> install.bat from dos, the kernel started to load then exited with an error
> message "cannot open image file for initrd" or something to that effect.
> Yet, when I ran loadlin from the dos command line with the exact same
> syntax as in the bat file, it worked. This problem could be related to my
> dodgey build. Will investigate further.

Enrique Zanardi					   ezanardi@ull.es

Reply to: