[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Observations on installing other Linux distribs

Over the last couple of weekends, I've been installing as many Linux
distributions as I can find on a spare machine sitting on my desk.
I've taken voluminous notes, included below, about the good and bad
points of each.  I thought that maybe the debian-boot list would be
interested in taking a look at my notes.  I'm not done installing all
the distributions that I'm going to, but you still might find the
results interesting.

Before anyone says anything, yes I am planning to put my code where my
mouth is.  It might be a while, though.

-*- text -*-

Test system configuration

* Intel Pentium/100 MHz

* Very cheap motherboard

* 48 MB RAM in 2x8 MB SIMMs + 2x16 MB SIMMs

* BusLogic PCI Fast SCSI card


* 3 1/2" floppy
* Color monitor that's lost most of its color, so complaints I make
  about colors below maybe shouldn't be taken seriously.

* DEC Tulip 10/100 Mbps Ethernet card

  - Connected to Linksys EtherFast 100BaseTX 4-port hub with one other

  - Other client is a Pentium II/233 with dual Ethernet running Linux
    2.1.122 and granting Internet access via IP masquerading to a
    10Mbps Ethernet connection.


  - Well in fact it does have a SCSI CDROM, but I'm out of 2-device
    SCSI cables at the moment.

Red Hat 5.2

* Uses SYSLINUX 1.40 for booting.

* Offers `expert' mode install.

* Looks horrible on monochrome monitor.

  - not after the SYSLINUX screen though.

  - but it still doesn't ask for color/monochrome selection.

* Kernel 2.0.36.

* Language selection.

* Doesn't make you tab over to the `OK' to select language, etc., like
  Debian boot disks do.  Enter works just fine for this.

* Uses a supplemental disk for special types of installs (ftp, etc.)

* Progress bars.

* `Install or upgrade' option... not in-place upgradeable?

* Workstation/server/custom selection

* Scans the SCSI bus for disks apparently, by itself... what is it
  doing really?

* Disk Druid: Lists all the disks on the system and the partitions on
  each, and allows add/edit/delete for partitions.  

  - Not superior to cfdisk by any means but more graphical.  

  - Makes you assign mount points to partitions, but it's not obvious
    that you have to do this before you go on.  (Well okay it's only
    not obvious if the partitions don't exist before you start.)

  - Growable? flag on partitions... what does this mean?

  - I found this tool difficult to use and unintuitive.

* Also offers text-based fdisk.
  - However it still pops you into Disk Druid afterwards to assign
    mount points to partitions.

* It found my tulip card automatically and started asking about IP
  address information.

  - It guessed my netmask from my IP address, correctly.

  - It guessed my gateway, incorrectly (but how could it know?)

* It tried to guess my hostname and domain but was unsuccessful,

* It asked me for FTP site information for installation but didn't
  default to ftp.redhat.com or any other site, somewhat

  - In addition, it was difficult to figure out what exact directory
    to tell it on the ftp site.  I was able to figure it out from the
    manual, though.
    (ftp://ftp.cdrom.com/pub/linux/redhat/redhat-5.2/i386 is what I
    ended up using.)

  - After figuring this out the ftp-based installation worked just
    fine.  It did have a problem at one point but it threw up a dialog
    on the screen and asked me if I wanted to retry.

* Doesn't include any useful command-line tools on the boot disk;
  i.e., when I had network trouble I couldn't invoke ping or telnet,
  or even ifconfig or route.

* Presents a nice list of categories from which to choose application
  types to install (i.e., printing, etc.), but it also lets you choose
  packages individually if you want, divided into categories.  I like

* Puts a log of how installation proceeded onto the hard drive.

* Hides the info about making filesystems, etc. from the user.

* Shows a progress bar as it installs apps, but not as it downloads
  them, unfortunately.  Progress bars for current package and total

* Estimates time to completion and shows time elapsed so far, and
  updates it dynamically; same thing for disk space used/needed.

* However there's still no cancel option while it's installing.

* It probed and found my touchpad acting in lieu of a mouse on cua0
  (why not ttyS0?) and allowed me to select what type of mouse it was
  and that 3 buttons had to be emulated

* Then it asked me to select my video card, but I wasn't sure what
  kind it was (some sort of Trident though) so I selected Unsupported
  VGA compatible and it downloaded & installed the VGA16 server for

* It asked about the monitor but as usual it wasn't on the list and it
  let me select from a range of standard monitor types.  After
  answering a few more questions I was too afraid to let it try it.

* After finishing that install it asked me whether I wanted to keep
  the current LAN configuration for permanent use or make a new
  configuration, or just cancel LAN totally.

* It asked me to select what services should be started automatically
  be default, but didn't give detailed information on what each
  service was.

* It asked me if I wanted to configure a printer (even though I hadn't
  installed the printer category) and let me say whether the printer
  was local, remote, or LAN manager.

  - local: specify queue name and spool directory, printer device (it
    even autodetected where there were printer ports although not
    whether printers were connected), then it let me select from a
    list of printer types, paper size, resolution, and whether I
    wanted anti-aliasing, and presented the results for verification.

* Asked for a root password.

* Asked if I wanted a boot disk.

* Asked where to install boot loader: /dev/sda or /dev/sda1.

* Asked for additional kernel boot parameters.

* Rebooted.

* Weirdly enough it cleared the screen after booting so that the last
  few boot messages didn't show.

* Tried X11 for kicks.  It installed fvwm95 as the default window

* Tried rpm but found its command-line interface incomprehensible.

* Ran glint but found it less than useful (how to tell it to download
  via ftp like the install disks?)

Caldera OpenLinux 1.2

* Cool opening screen :-)

* Kernel modified to display different than usual boot messages.

* Language selection.

* Option to use previously saved configuration.

* Faux 3D buttons :-)

* Drivers:

  - Loads SCSI drivers, etc. separately from explicit menu selections.

  - Autoprobe routines offered but optional.  Autoprobe progress can
    be followed on consoles 6 & 8.

  - After autoprobing allows you to review what's been detected.

  - Didn't detect the tulip card, but it was on the separate modules
    diskette and it let me load it manually and allowed me to specify
    module parameters, then reported success to me.

* Disks:

  - It allowed me to start plain text mode fdisk, after warning me
    several times.

* Offered CD-ROM, hard disk, and NFS install, but not FTP.  NFS
  install turned out to be a big pain until I realized that it indeed
  did tell me what exactly I had to copy from the server if I pressed
  F1, stupid stupid me., BTW.

* Doesn't shield user from mke2fs output like Red Hat.  Is this good?

* Gave a number of pre-selected packages options (minimal, minimal
  w/X11, small standard, standard, all packages, quick & compact
  selection, individual series selection).

* Allowed me to select an X server from the list (chose VGA16).

* Brought up a separate dialog for each package install, with overall
  installation progress bar but not individual package progress bar,
  also an indicator saying how much of the hard drive space was
  available.  Nasty screen flashing between package installations.

* After it installed all the package it ran their postinsts, also
  flashing the screen nastily

* Colorized full version of ls on boot disks :-)  Boot disks include
  standard assortment of utilities

* After everything installed it asked me about my network settings all
  over again even though it'd been installing via NFS.  It even forgot
  my DNS server address.

* Asked about NIS settings (so did Red Hat, actually), timezone
  settings, local vs. GMT.

* Asked about mouse type, mouse port, printer type (but weirdly no
  standard PostScript printer available), root password (dropped into
  console mode for this), warned about using root account.

* Asked about a new user, UID, group/GID (showed a list), home
  directory, shell, full name, all in separate dialogs, then dropped
  to console mode for password.

* Asked about CD-ROM drive type.

* Detected existing LILO configuration and offered to replace it with
  a new one, giving several options for install location.  Offered to
  boot from two different kernel images (/vmlinuz,
  /boot/vmlinuz-2.0.35-modular), why?

  - Asked if I wanted an initial ramdisk and set default to
    /boot/initrd.gz.  Why?

  - Asked for boot entry label.

  - Asked for boot parameters.

  - Finally let me add more to the LILO list or stop.  Then it showed
    me the LILO configuration file and offered to install as
    configured; I let it and it appeared to work okay.

* Allowed me to select services to start at boot.

* Offered to start XF86Setup for me.

* Offered to save current configuration to diskette.

* Cool: it didn't reboot, it just killed most of the processes and
  booted to the partition.

* Built-in NetWare client support.

* Default window manager is fvwm2.  Nice menu layout but nothing
  special in the way of programs besides ``Looking Glass

OpenBSD 2.3 and 2.4

* Uses an apparently OpenBSD-specific bootloader on its boot floppy.

* Couldn't get it to boot even with its cool commandline interactive
  interface for enabling and disabling devices.

* Hung in boot sequence.

NetBSD 1.3

* Seems to think I have an NE2000 at 0x300 and IRQ 10 even though I
  have a perfectly respectable Tulip card.  Wouldn't boot because of

FreeBSD 3.0

* Similar boot to FreeBSD, but it has a *TUI* interactive interface
  for enabling/disabling devices that works really nicely, and let me
  disable all ISA Ethernet devices.

* Starts up with old Slackware or new Debian reminiscent installation
  interface.  Interface is distinctly quick.  

* You can set up options in a forms-input style interface.  

* After that there is a choice of novice, express, or custom
  installation.  Chose novice.

  - Brought up a new screen allowing me to fdisk graphically, with
    even a `use entire disk' option.  Tried that: it asked me whether
    to make a true partition table, but I declined.  Helpful F1 help
    was available.

  - Next it brought up the BSD disklabel editor (also graphical).
    Also some F1 help here with advice on designing partition sizes.
    Created a swap partition and a root partition easily.  (I wish
    that these editors would allow sizes to be specified in MB rather
    than blocks!)

* Offered some canned installations.  Chose `X-User'; binaries and
  docs plus X Window System; no developer tools.

* Asked whether to install DES.

* Offered to install XFree86.

* Asked install media: CDROM, ftp, ftp passive/firewall, DOS
  partition, NFS, existing filesystem, floppy, tape.

  - Selected ftp; brought up a list of ftp mirrors and allowed one to
    be chosen.  Asked standard questions about the network
    environment in a nice-looking form.

* Gave a last-chance bail-out in case of lost disk contents
  (apparently doesn't do real disk partitioning until this point?

* Warned about no /usr or /var filesystem.

* For some reason the floppy drive light never went off.

* FTP install didn't work through my masquerading network and it
  sig11'd when I tried to cancel, then it self-rebooted.

* Retried with passive FTP install and everything succeeded.  It
  displayed a progress bar for total installation as well as a status
  line at the bottom of the screen showing total ftp bytes read,
  number of chunks read, K/sec.

* Eventually failed with errors on SCSI controller (might be hardware
  problems but none of the Linux distribs had trouble).

Slackware 3.6

* Boot floppy with LILO, with separate root floppy.  Choice of a few
  different root floppies.  Chose color interactive root floppy.

* Root floppy starts by having you log in as root.  Set TERM to vt100
  to turn off color, then ran `setup'.

* `setup' told me I didn't have any Linux partitions and that I should
  run `cfdisk', so I quit `setup' and did that.  `cfdisk' didn't like
  FreeBSD's leftover disk label, so I had to run command-line fdisk

* setup allowed me to add a swap partition and format the filesystem
  partition.  It even asked me how many inodes I wanted.

* It asked me for installation media: CDROM, hard drive, NFS,
  pre-mounted directory, floppy disk.

  - Selected NFS, asked standard networking questions.  Stupid
    keyboard setup made me press Shift+NumLock to turn on NumLock,
    though, and even then the numeric keypad didn't work.

  - Didn't work because the kernel didn't know about the Ethernet
    card.  Checked the list of boot disks again, and I'd picked the
    wrong one.  One of the problems with this install is that there's
    too many boot disks; it's too hard to pick the correct one.

  - Even after I picked what appeared to be the correct one, it
    crashed after the SLIP/PPP messages in the kernel boot.  I'll have
    to build my own kernel for this.

Stampede 0.86

* LILO on boot disk with short, unhelpful message.  Boot disk has
  practically no drivers.  Separate root disk.

* Root disk booted to login prompt, invited to log in as `root'.

* Setup very similar to Slackware.  I was irritated that I had to
  create a custom kernel just to make it work at all (none of the
  standard boot disks supported BusLogic SCSI).  This seems funny
  considering that Stampede is AFAIK supposed to be an `easy to use'

* Does not include cfdisk, just fdisk.

* Weirdly enough it offers swap partitions as target partitions and
  filesystem partitions for swap partitions.

* Install media: premounted directory, CDROM, floppy, FTP, NFS,
  directly from /mnt.  Selected FTP but it said that that install
  method wasn't available yet, so I mirrored the hyperion-0.86 tree to
  my machine and installed via NFS instead.

* Selecting packages is painful because it doesn't have a useful
  default list, although packages are divided into categories, and the
  setup program displays weird sh error messages between screenfuls.

* Apparently no package dependencies.

* The install apparently just untarred files directly to the hard
  drive; no progress bar or anything like that, just a brief
  description of each package as it was extracted.  At least there was
  a `Percentage of Packages Installed: NN/100' line at the bottom of
  the dialog box.  The screen flashed as each package was installed.

  - As it turns out, it displays slightly more detailed information on
    tty 4 while installing, but this isn't advertised anywhere.

* I ran network config, which was pretty standard, although `network
  address' is not a good synonym for `netmask'.

* LILO config let me tell it what I wanted to add to the LILO config
  and where LILO should be installed, also the delay before booting
  the default image, also kernel parameters.

* Mouse config: select mouse type, mouse port.

* Modem config: select modem port.

* Exited setup program.  Then Ctrl+Alt+Del to reboot.  Unfortunately
  its LILO setup apparently had failed without telling me because it
  said `no bootable partition' at boot-up and I had to boot via rescue

* Once I did boot from the rescue disk it just dumped me at a login
  prompt with no hint as to where to go from there.  I was tired of
  this so I went on to the next install immediately.

TurboLinux 2.0

* Boot message referred me to the Users' Guide for installation help.
  Single boot disk.

* Asked me whether I had a color monitor, keyboard type, whether I
  have PCMCIA.

* Told me to insert `extra hardware disk', although it did give a
  `Skip' option.

  - I think that I put in the wrong version of the extra hardware
    disk, but it didn't tell me that, it just gave some random error

  - Rebooted and tried the newer version, that worked better.

  - Progress bar while reading the hardware disk.

* It switched to a big text mode, maybe 40 or 50 lines.

* Offered to probe for hardware devices, asked whether I needed
  parallel port IDE support to install.

  - Porbed for network adapters, SCSI adapters, and showed a list of
    what it had detected.

* Offered installation method selection: CDROM, NFS, hard drive
  partition, FTP, SMB.  Chose FTP.

  - Wanted supplementary install disk.

* Offered `normal' or `extended' verbosity dialogs, chose normal.

* Asked if I had a LAN and if I had PPP, told it LAN.

* Asked me again about my SCSI card, why?

* Offered fdisk and cfdisk, just told it I was done.

* Allowed it to format the swap partition and the filesystem

* Presented a format for configuring TCP/IP.

  - Tried to guess host name/domain name but couldn't, unsurprisingly.

  - Asked again about nameservers, why?

* Offered to proxy outgoing TCP/IP.

* Allowed me to choose a TurboLinux mirror site.

  - Couldn't resolve the hostname through the masquerade for whatever
    reason, maybe my fault.

  - Didn't finish out install since the whole thing is so Red Hat
    derivative anyway.

Solaris 2.6

* Asked whether I wanted an existing or new configuration.  Chose new.

* Offered full or partial device scan.  Chose partial since I'd run
  this before and knew that full would fail.

  - It `enumerated the buses' and found everything without trying very

* Asked for install media, told it the Ethernet.  It was unimpressed,
  and didn't ask for IP address or anything else.  It just hung.

* Sun had thoughtfully included a documentation CD, so I popped it
  into the other Linux box and looked at it.  But you can't read the
  documentation CD without an already working Solaris install,
  apparently.  Idiots.

* I eventually figured out, from the scripts that Sun provided for
  setting up a Solaris network install server, that I needed to set

  - RARP, so that the machine could figure out its IP address.

  - bootpd, so that the machine could grab some of its basic files.

  - bootparamd, so that the machine could know where its install files
    were coming from.

  - NFS, to export all the appropriate directories.

* After a while I managed to get it to boot the kernel, simply to have
  it die right afterwards and spew some messages then reboot without
  waiting for me to read them.  Then I managed to see it referring to
  NFSv3, which isn't yet supported by Linux, so I gave up.


* Caldera-like kernel boot messages

* Asked about PCMCIA support

* Offered CDROM, hard drive, NFS, FTP, SMB, SCSI tape, floppy
  rescue-only install.  Selected FTP, asked for supplementary disk,
  loaded supplementary disk with progress bar.  Hung hard after
  loading the supplementary disk.

* Retried with NFS install.  Asked about network driver to use,
  selected Tulip and autoprobe.  Asked about network settings, gave
  bootp option as well; tried it, it worked.  Asked about domain name,
  host name, additional nameservers.

  - The default NFS server doesn't exist, apparently, so why do they
    give a default?

  - Had to mirror the linuxpro install tree locally to complete
    install.  Gave it for

* Asked if I have SCSI adapters, I selected mine from a list and told
  it to autoprobe.

* Let me run (CLI) fdisk on /dev/sda.

* Asked for swap partition, root partition, formatted both.

* Let me pick some categories of packages to install or invididual

* Installed everything.

  - However many packages reported that running the install script
    failed, mysteriously, without any other explanation.  Presumably
    there's more about this in the log file, but nothing else appeared
    on console 3 that lists some interesting info as packages install.

* Asked about mouse type, emulate 3 buttons?, port; video card,
  monitor, clockchip, run X -probeonly?; PPP?; timezone; printer?;
  root password; LILO location, extra options.

* Built initrd for LILO boot, then crashed.  Did not complete this

SuSE 5.2

* Has several different boot disks for different hardware.

* Booted to SYSLINUX with graphical intro screen.

* Choice of 4 languages; color/mono; keyboard.  Exploding windows!

* Main menu with settings, system information (dmesg, etc.).  Also can
  load particular modules (SCSI, CDROM, network), or start
  installation process.

* Install via CDROM, NFS, FTP, HDD.

* FTP installation offers bootp configuration; standard network
  configuration questions.  Demands IP address of FTP server but
  allows hostname anyway.  Even so it managed to get the wrong IP
  address and I had to nslookup from another machine.  Allows username
  and password to be specified for FTP, optional ftp proxy.  Asks for
  server directory (turned out to be /pub/SuSE-Linux/5.2).

* Asked if okay to use current swap partition.  It noticed that it had
  a swap signature already and offered to not rewrite it.

* Offered to read a previously created disk containing installation

* Offered to install from CDROM, NFS, `a reachable directory', or HDD
  partition.  (No FTP.) Asked for all the network information again.

* Had to mirror the SuSE site to install via NFS.

* It let me choose a target partition, etc., via a nice TUI interface.
  The order to do things wasn't obvious, though.

* It offered to save configuration info to a floppy.  I chose `no' but
  it reformatted my SuSE install disk anyway.

* After doing `choose/create configuration' and not changing any of
  the defaults, I did `start installation'.

* Haven't finished with this one yet since I didn't get around to it;
  I did have to mirror the entire SuSE 5.2 site in order to continue.

Reply to: