[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [GSoC] Rewriting tasks.py to exclusively use UDD



Hi Akshita,

On Tue, May 19, 2015 at 09:36:14PM +0530, Akshita Jha wrote:
> I have been working on debian-science tasks page issue - about the missing
> descriptions and maintainers for certain packages. Although I haven't been
> able to find anything conclusive yet, I will continue working on it.

I have another data point with the very same problem:

   http://blends.debian.org/med/tasks/bio#subread

As I said previously my gut feeling is that there is a bad architecture
+ experimental release combination which leads to this effect.  There is
the "fun-Blend" which I created for "fun and debugging" where you can
tweak the tasks to a bare minimum to focus on the problematic packages
without influencing any real Blend.
 
> On the other hand, I wanted to start the actual task of rewriting tasks.py
> to exclusively use UDD. Do you have any points that I should keep in mind
> before getting started and anything specific that I can start with ?

I would start by skipping anything that is accessing the tasks files
directly and start with all information you can get from there.  It
might have some advantage if you could create a data output in JSON
format (which was influencing the bugs_udd script.  The reason is that
NeuroDebian would like to use this output to create their own pages.

However, I would not make this a preference since I noticed that the
code becomes quite hard to read that way and I would prefer clean code
over this feature.  The rationale behind this is that it might turn out
to be a misfeature from a taktical point of view since it allows this
team to play in their own playground rather than using and enhancing
Blends tools directly. ;-)

I have no other general hints except that it might probably be the best
to start coding from scratch since the hackish coding of the existing
tasks.py + used modules might not very helpful to get a clean design.
Re-using the SQL queries (after checking!) might make sense.

Hope this helps

     Andreas.

-- 
http://fam-tille.de


Reply to: