[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Thermometer not updating

Hi Bas,

On Tue, Oct 15, 2013 at 11:18:37PM +0200, Andreas Tille wrote:
> Hi,
> On Tue, Oct 15, 2013 at 08:05:27PM +0200, Sebastiaan Couwenberg wrote:
> > The thermometer that was introduced for the Debian GIS Blend doesn't
> > appear to be updating anymore.
> > 
> > When I run the query from webtools_thermometer.py manually on UDD, it
> > returns no results.
> > 
> > There are no records in the blends_dependencies,
> > blends_dependencies_alternatives and blends_tasks tables.
> I need to check this tomorrow.  I can confirm the problem and somehow
> the importer of the Blends data seems to have a problem (which is
> somehow possible since I recently changed something).
> > I haven't found the script in the blends repos which updates these
> > tables, so I'm a bit of a loss how to fix this.
> This is in
>     git://git.debian.org/git/collab-qa/udd.git
> and I think it is a bit overkill if you want to dive into UDD
> internals (well, I will not stop you from doing so - but I think
> the problem can be easily solved tomorrow).

The problem seems to be more compley than expected.  I noticed that the
Blends metadata were not updated in UDD for way longer than expected and
that this fact just showed up when I changed the table structure
yesterday.  The problem is not directly related to the importer code
(except that it might be more error tolerant which I try to change now).

I've sended a call for help to debian-qa list (Bas was in CC to keep
him informed about the issue).

Kind regards



Reply to: