[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Missing required package is not missing?

On Wed, Sep 26, 2007 at 06:16:45PM -0400, Ernesto Hernandez-Novich wrote:
> I'm building a Debian Etch CDD for my students at a local university, so
> they get Haskell, all the libraries they need and the lecture slides for
> the course I teach. I do my CDD building on a Debian Etch machine (up to
> date as per s.d.o) where simple-cdd 0.3.4 has been installed manually. I
> have a full Debian mirror at my office.
> I followed the Quick Start as explained
> in /usr/share/doc/simple-cdd/README: 

oh dear... i didn't realize how out of date that was... i'm sorry.

please use the instructions from the wiki page:


i will make sure the README gets updated soon.

> 1. Installed the required packages.
> 2. Got the etch-simple-cdd using bzr, no problem.

that bzr branch is no longer maintained... the current development
branch actually works better with etch, in my experience.  but i would
recommend sticking to using the package, rather than bzr branches. 

> 3. Got into the working directory and created profiles/ci3725.packages
> (ci3725 is my course code) with three lines
> alex
> happy
> haddock
>    since those are simple and small packages and just wanted a quick
> test.
> 4. Built the .udeb using debuild, no problem.
> 5. Ran
> ./build-simple-cdd --profiles ci3725 \ 
>                    --local-packages \
>                      ../simple-cdd-profiles_0.3.0~1_all.udeb
>    which ran successfully creating an ISO that had the packages there.
> Joy!
> Then I repeated the _whole_ procedure from scratch on a _new_ working
> directory, just adding one single line to the packages file
> ghc6
> which is the Glasgow Haskell Compiler (essential for this CDD). This
> time I got no joy, getting an error message instead
> ERROR: missing required packages from profile ci3725:  ghc6
> I've checked:
> 1. The package was downloaded into the working directory. It's in
> ./mirror/pool/main/g/ghc6/ghc6_6.6-3_i386.deb
> 2. All its dependencies where also downloaded into the working
> directory. I've checked them manually. Twice.
> 3. Somehow, it doesn't make it into ./tmp/cd-build/etch/CD1/pool
> I removed ghc6 from the package list, and it worked again. I added
> ghc6-doc (which is built from the same source package as ghc6 is) and it
> worked too.
> What am I missing?

hard to say, usually something is missing a dependency that's only
provided through a "Provides" line. for example, xorg's dependency on
"sparc-utils | not+sparc", "no+sparc" is provided by the type-handling
package on architectures other than sparc.

i'll see if i can reproduce it.

the only thing in your profile is profiles/ci3725.packages:



live well,

Reply to: