[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Missing required package is not missing?


I'm building a Debian Etch CDD for my students at a local university, so
they get Haskell, all the libraries they need and the lecture slides for
the course I teach. I do my CDD building on a Debian Etch machine (up to
date as per s.d.o) where simple-cdd 0.3.4 has been installed manually. I
have a full Debian mirror at my office.

I followed the Quick Start as explained
in /usr/share/doc/simple-cdd/README: 

1. Installed the required packages.
2. Got the etch-simple-cdd using bzr, no problem.
3. Got into the working directory and created profiles/ci3725.packages
(ci3725 is my course code) with three lines


   since those are simple and small packages and just wanted a quick
4. Built the .udeb using debuild, no problem.
5. Ran

./build-simple-cdd --profiles ci3725 \ 
                   --local-packages \

   which ran successfully creating an ISO that had the packages there.

Then I repeated the _whole_ procedure from scratch on a _new_ working
directory, just adding one single line to the packages file


which is the Glasgow Haskell Compiler (essential for this CDD). This
time I got no joy, getting an error message instead

ERROR: missing required packages from profile ci3725:  ghc6

I've checked:

1. The package was downloaded into the working directory. It's in


2. All its dependencies where also downloaded into the working
directory. I've checked them manually. Twice.

3. Somehow, it doesn't make it into ./tmp/cd-build/etch/CD1/pool

I removed ghc6 from the package list, and it worked again. I added
ghc6-doc (which is built from the same source package as ghc6 is) and it
worked too.

What am I missing?
Ernesto Hernández-Novich - Linux 2.6.18 i686 - Unix: Live free or die!
Geek by nature, Linux by choice, Debian of course.
If you can't aptitude it, it isn't useful or doesn't exist.
GPG Key Fingerprint = 438C 49A2 A8C7 E7D7 1500 C507 96D6 A3D6 2F4C 85E3

Reply to: