[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Pbuilder problem

Op 06-09-18 om 21:52 schreef Rodrigo Campos:
> On Thu, Sep 06, 2018 at 09:40:37PM +0200, Paul van der Vlis wrote:
>> Hello,
>> I use pbuilder for backporting packages. My problem is that a package
>> does not build, when there are build-dependencies from backports.
>> What can I do to make this work?
>> Some more info:
>> For example the package dh-linktree does not build, because debhelper >=
>> 11 is needed, what's in backports. How do you backport such a package
>> with pbuilder?
> You can modify the sources.list that the chroot uses, and just add the backports
> repo

What is the correct way to modify the chroot?  I have tried things like:

mkdir /tmp/test; cd /tmp/test/
tar zxpf /var/cache/pbuilder/stable-amd64-base.tgz
nano etc/apt/sources.list
tar cfz ../stable-amd64-base.tgz .

Is this a good way?

It does not work, I get now:
I: Extracting source
/sbin/start-stop-daemon: unable to start /bin/sh (Permission denied)
E: pbuilder: Failed extracting the source
Not sure what this is.

What I saw, is that stable-amd64-base.tgz has in sources.list lines with
"stable", but for backports it has "jessie-backports"!  I have changed that.

When I run:
sudo pbuilder --create --distribution stretch
It's creating a testing-amd64-base.tgz
When I try to login with:
pbuilder --login --distribution stable
I see it's using testing-amd64-base.tgz

Very confusing. Is there something wrong on my system, is this a bug, or
is this normal?

With regards,

Paul van der Vlis Linux systeembeheer Groningen

Reply to: