[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation error of nfs-common

On 09/30/2011 07:26 AM, Daniel Kahn Gillmor wrote:
> Hi Roel and Bernhard--
> [rearranged for chronological order]
> On 09/27/2011 02:13 AM, Roel Hendriksen wrote:
>> 2011/9/26 Bernhard Schmidt <berni@birkenwald.de>
>>> installing nfs-common from squeeze-backports with rpcbind (instead of
>>> portmap for IPv6 capability) breaks in the postinst step.
>>> Setting up nfs-common (1:1.2.4-1~bpo60+1) ...
>>> insserv: Service portmap has to be enabled to start service nfs-common
>>> insserv: exiting now!

>>> The initscript has Required-Start $portmap, but the rpcbind initscript does
>>> not provide this. I'm not aware of an OR statement in the LSB headers, so I
>>> guess one option would be to backport rpcbind 0.2.0-5 which should fix that.

Yes, but not completely unfortunately...

>> I have the same experience when installing nfs-common from backports.
>> Libtirpc1 is installed as a dependency, but portmap is uninstalled, which
>> gives errors later on.
> I produced this backport, and i've been able to install the packages
> without a problem.  (i also use rpcbind instead of portmap):
> 0 bobtail:~# apt-get install --reinstall nfs-common

This works because you do a reinstall instead of starting from a clean

> hmm, it appears that having portmap in the removed/configfiles state
> allows things to proceed, but if portmap is purged (no configfiles) then
> the failure happens:

This is a side effect, but is not guaranteed to solve the issue...

> this is unfortunate; it appears to be related to
>   http://bugs.debian.org/565201
> which was solved after squeeze was released.

Indeed in 2 steps, one of which is solved in rpcbind, though it needs a
change in insserv too.

> I think the solution should be to set up an extra insserv.conf.d
> advisory, but it doesn't work for me:
> 0 bobtail:~# printf '$portmap\trpcbind\n' > /etc/insserv.conf.d/rpcbind

That does not work as the central config of insserv does not allow it,
it only allows portmap.

So the solution is to drop the portmap definition in insserv (like in
1.14.0-2.1) and to have rpcbind define portmap like I did after squeeze.



Reply to: