[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: linux-image-2.6.39-bpo.2-amd64: hibernate doesn't ever resume

On Fri, 23 Sep 2011 06:06:42 -0400
Thomas Shanks <reportbug@tshanks.org> wrote:

> This grub config change works for me.  Thank you.

You're welcome. Glad it worked!
> What can be done to fix the bug of automatically enabled low-battery
> hibernations that don't resume properly (= loss of data/session)?

I don't know.  
> Why isn't this hack needed for the squeeze non-bpo kernels?

For my desktop pc, neither hibernate or suspend worked when booted to
squeeze so that's why I installed the bpo kernel, hoping it would start
working. When that didn't fix it, I did some research and the info. I passed
along fixed hibernation. The funny thing is, I have an old laptop with the
original 2.6.32 for i386 squeeze kernel installed, and suspend works fine but
hibernate doesn't work at all. I can live with suspend working, though.

> What adds those lines to grub on wheezy?  Can it be backported to squeeze
> (stable or bpo)?

I'm booted to wheezy right now on the pc, and I checked the grub file
mentioned below, and it shows GRUB_CMDLINE_LINUX="" only, yet suspend and
hibernate work. So there's something else at work. My wheezy desktop is xfce,
and I have pm-utils 1.4.1-8 and the xfce4-power-manager installed. 

On the laptop I also have an xfce desktop, with pm-utils 1.3.0-3 as well as the
xfce4-power-manager and a package acpi-support 0.137-5 that may or may not
need to be installed.

So perhaps it's a difference in the pm-utils? I'm not sure...

> On Sep 22, 2011 11:00 AM, "Cia Watson" <ciamarie@my180.net> wrote:
> > On Wed, 21 Sep 2011 22:30:31 -0400
> > Thomas Shanks <reportbug@tshanks.org> wrote:
> >
> >> On Mon, 19 Sep 2011 18:06:56 Cia Watson <ciamarie@my180.net> wrote:
> >> > revised my file to remove the single quote so it shows something like:
> >> > RESUME=UUID=some-number
> >>
> >> This causes no change here. It still behaves as in the bug report.
> >
> > I just looked back at my notes, and found something else to check. Also,
> my
> > message was more for the devs, since it appears that when the new kernel
> > revised the resume file it added a quote that didn't belong there. But,
> check
> > /etc/default/grub and you may want to revise it to look like:
> >
> > GRUB_CMDLINE_LINUX="resume=UUID=number of swap partition vga=792"

Reply to: