[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: linux-image-2.6.39-bpo.2-amd64: hibernate doesn't ever resume on Arrandale

On Mon, 19 Sep 2011 01:59:07 -0400
Thomas Shanks <reportbug@tshanks.org> wrote:

> On Mon 19 Sep 2011, intrigeri <intrigeri@boum.org> wrote:
> > I've seen such resume from hibernation issues on similar hardware.
> > Kernel 3.0.0-1 did not fix it, but 3.1.0-rc4 did. YMMV.
> Thank you for your reply.
> Can you elaborate on whether this is indeed an upstream kernel bug?
> Do you know what goes wrong in the suspend image finding or
> restoration?  How can one check if this is a presentation of that bug?
I'm running wheezy and have squeeze installed on another partition. Until I
installed virtual box, I was booting to squeeze so printing would work due to
a bug in the c2esp package. I tried installing the 2.6.39 bpo kernel and
there was a dependency issue I didn't want to play with, but I did manage to
install 2.6.38 bpo kernel, since hibernate didn't work with the original
kernel, and hibernate didn't work for me with the bpo kernel either. 

Both suspend and hibernate worked for me when booted to wheezy on the same pc
using the 2.6.39 kernel as well as with the current 3.0 kernel. This is on a
desktop pc, not a laptop. Here's text from a message I posted on
debianuserforums.org about this topic, in case it's helpful:

I finally got hibernate to mostly work. Mostly, just because when it goes
into hibernation it acts more like 'restart' than 'shut-down' -- in that it
powers off then right back on again. I have to manually push the power button
when it re-starts. But when I go back it's back to the desktop I hibernated
from. Suspend still doesn't work, however.

When I installed the 2.6.38bpo kernel it wanted to change the /dev/sda2 I had
in /etc/initramfs-tools/conf.d/resume to the proper UUID for the swap
partition, so I said sure, go ahead. I was reading some messages on another
forum about hibernate issues, and someone posted the output of their resume
file noted above, and I double-checked mine and it was showing a single quote
around the UUID= whereas the person posting an example showed no quote, so I
revised my file to remove the single quote so it shows something like:

Reply to: