[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrading Lenny to Squeeze with backports involved


* Ignacio Vazquez Alvarez <ivazquez@s21sec.com> [2011-02-10 15:42:37 CET]:
> This is may situation:
> I'm using Lenny with Nagios3 installed from lenny-backports and now I'm  
> thinking to upgrade the whole system to squeeze and I was wondering if  
> there are special things to care about.

 Actually with the exception of a small amount of packages we don't have
any violation of the rule that lenny-backports only contains versions of
packages smaller than squeeze, so there is nothing to take care of if
you only use lenny + lenny-backports and want to upgrade to squeeze.

 For the record, the three packages that are newer than in squeeze are:
duplicity, libdatetime-format-flexible-perl, libdatetimex-easy-perl.

> Because the Nagios3 version is the same both in lenny-backports  and  
> squeeze (logically) I'm thinking in setting this sources.list:
> deb http://ftp.se.debian.org/debian/ squeeze main contrib non-free
> deb-src http://ftp.se.debian.org/debian/ squeeze main contrib non-free
> and executing the update/dist-upgrade.
> Can you confirm if this correct?

 Yes, this should do exactly what you want. :)

"What are the differences between Mark Zuckerberg and me? I give private
 information on corporations to you for free, and I'm a villain.
 Zuckerberg gives your private information to corporations for money and
 he's Man of the Year."         -- Julian Assange

Reply to: