[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

samba unmet dependencies


I just want to point out an unmet dependency.
I've been trying to upgrade my version of samba to the current one available in backports, but I get this problem:

$ sudo aptitude -t lenny-backports install samba samba-common smbfs smbclient
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Reading extended state information     
Initializing package states... Done
Reading task descriptions... Done 
The following packages are BROKEN:
The following NEW packages will be installed:
The following packages will be upgraded:
  libwbclient0 samba-common smbclient smbfs
5 packages upgraded, 1 newly installed, 0 to remove and 48 not upgraded.
Need to get 26.5MB of archives. After unpacking 16.2MB will be used.
The following packages have unmet dependencies:
  samba: Depends: libpam-runtime (>= 1.0.1-11) but 1.0.1-5+lenny1 is installed.
The following actions will resolve these dependencies:

Remove the following packages:

Score is -9881

The package libpam-runtime is currently not provided in backports and the version in lenny is not enough.


Reply to: