[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem pinning openoffice from lenny-backports

	I had started a similar thread in September, so I'll try to contribute 
here... The results of the discussion back there were:
1- you cannot pin openoffice in any distribution by simply giving it priority 
higher than 500, since you would need to pin all openoffice.org* packages and 
apt/preferences does not allow that: you'd have to list **explicitely** one 
by one all packages openoffice.org-base, openoffice.org-calc, etc.
2- the second best option is what's explained in the backports.org 
instructions page, that is install it manually once as you did and
pin openoffice.org/backports with priority 200. After the manual install, 
priority 200 is enough to let apt automagically upgrade openoffice when a new 
version is added to backports. At least it was working for me during the last 
months of etch...

Regarding your error message, I cannot help on that. The only suggestion is 
that, when I had troubles with apt, I found very useful to run "apt-cache 
policy packagename".

Best regards,

Alle domenica 5 aprile 2009, Ken Heard ha scritto:
> Tim Cutts wrote:
> <snip>
> > Would it not have been simpler just to have done:
> >
> > aptitude install openoffice.org/lenny-backports
> That is what in effect I did, but with a slightly different command:
> "aptitude -t lenny-backports install openoffice.org", which was successful.
> > I don't think pinning is necessary here.
> No, it is not; but I thought I would take the opportunity to learn how
> to pin.  Obviously I failed.
> I did however want to be able to have backport packages upgraded
> automatically in accordance with the following from the backports
> instruction page:
>  If you want to get your packages from backports upgraded automatically
>  the following entry in /etc/apt/preferences should be sufficient:
> 	Package: *
> 	Pin: release a=lenny-backports
> 	Pin-Priority: 200
> After I got OpenOffice.org version 3 running I put those three lines --
> and *only* those three lines -- in file /etc/apt/preferences.  Then when
> I ran aptitude update I got back the same error message:
>  E: Invalid record in the preferences file, no Package header
> So I still don't know how to pin, and I would still like to know what I
> am doing wrong, in particular so that I can have backport packages
> upgraded automatically.
> Ken Heard

Reply to: