[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem pinning openoffice from lenny-backports

On 3 Apr 2009, at 7:47 pm, Ken Heard wrote:

I wanted to install openoffice.org 1:3.0.1-7~bpo50+1 from
lenny-backports/main to replace version 1:2.4.1-17+b1 provided by

First, I added lenny-backports to /etc/apt/sources.list and then ran
"aptitude update". I decided to use pinning in order to give priority to the later verson. In accordance with the pinning instructions provided on the backports instructions page, I created file /etc/apt/ preferences
with the following content:

Package: openoffice.org
Pin: release a=lenny-backports
Pin-Priority: 990

When I ran "aptitude upgrade" openoffice.org 3 was not installed, and
the following error was returned:

Would it not have been simpler just to have done:

aptitude install openoffice.org/lenny-backports


I don't think pinning is necessary here.


The Wellcome Trust Sanger Institute is operated by Genome Research Limited, a charity registered in England with number 1021457 and a company registered in England with number 2742969, whose registered office is 215 Euston Road, London, NW1 2BE.
Reply to: