[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: rails backports

(please cc me on replies)

Jan Wagner wrote:
> On Sunday 27 January 2008 07:53, Adam Majer wrote:
>> Do I need to change the version of rails and rebuild it, or can I just
>> upload the same package I uploaded for rails 1.2.6-1?
> <cite="http://backports.org/dokuwiki/doku.php?id=contribute";>
> Reconsider if the package can be installed directly from testing without any 
> recompilation and handled via pinning[1]</cite>

1.2.6 is not in testing - it *was* in testing. It is not in stable
either. That is the issue here. 1.2.6 has a lot of fixes not available
in current stable, but stable policy will not allow it into Etch.

1.2.6 is quite compatible with the 1.1.6 in Etch. It is the best of the
1.x rails branch. I'm actually using it for an application that does not
work with 2.x branch.

On the other hand, the 2.0.2 (later version in future) is less
compatible and probably should not be backported. It is readily
available and installable almost directly from current testing/unstable
repository for people running Etch.

- Adam

Reply to: