[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: backporting GPLv3 packages


On Thu, Sep 13, 2007 at 11:25:24AM +0200, Santiago Vila wrote:
> On Fri, 7 Sep 2007, Robert Millan wrote:
> > Oh, there's another problem I didn't spot.  When 4.0.1 is changed to
> > 4.0.1~bpo.1, it stops matching >= 4.0.1 dependencies.  Should we
> > make an exception for base-files, or fix all packages that depend on
> > it when backporting instead?
> I think it would be perfectly ok to call it 4.0.1.bpo.1 or something similar.

I think this should be handled like any other dependency which can only be
satisfied from backports.org, i.e. the backporter has to adopt the version of
the dependency to match bpo when creating the backport.


Sebastian "tokkee" Harl +++ GnuPG-ID: 0x8501C7FC +++ http://tokkee.org/

Those who would give up Essential Liberty to purchase a little Temporary
Safety, deserve neither Liberty nor Safety.         -- Benjamin Franklin

Attachment: signature.asc
Description: Digital signature

Reply to: