[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Possible Problem with libapache2-svn?

Sorry, don't have time to debugg the problem right now; so this is just
an other "maybe there is a problem, but I don't know where" mail.

I have apache2-mpm-prefork 2.0.54-5sarge1 running, and tried to install
libapache2-svn and subversion from backports.org.

The package installed without problems (pulling in libneon24 and
libsvn0), but restarting apache failed:
Syntax error on line 2 of /etc/apache2/mods-enabled/dav_svn.load:
Cannot load /usr/lib/apache2/modules/mod_dav_svn.so into server:
	/usr/lib/apache2/modules/mod_dav_svn.so: undefined symbol: dav_xml_get_cdata

Okay, so I downgraded libapache2-svn to sarge's 1.1.4-2; which pulled in

Restarting apache worked.  So I gave backports.org version an other try
(thought maybe just some missing dependencies).  So upgrading
libapache2-svn from 1.1.4-2 to 1.4.2dfsg1-2~bpo.1 (and aptitude removing
db4.2-util again), and guess what?  Problem solved.  Apache2 restarts
without any problem.

Maybe someone can reproduce the problem; I don't have the time for it
right now.  If you like I can put the logs of aptitude and apache
somewhere online.

Yours sincerely and thanks for alle the work,

Attachment: signature.asc
Description: Digital signature

Reply to: