[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: bpo's udev broke my vpn server

madduck@madduck.net said:
>> Here in an up-to-date backport of udev:
>> http://people.backports.org/~tretkowski/upload/udev/
> The topic makes me think: "don't run udev on a 'server'". But that's
> another thread at another time in another place.

actually, the reason I _am_ running it on a server is because it's one
with many network devices, and I want control over how they're named.
That approach is working very well on my firewall, which has 8 ethernet
devices, 4 vlans, and a bridge. It's much easier to keep everything
straight when the interfaces have meaningful names.

The problem I experienced was on another sarge+backports vpn server,
which had udev installed because I have interface renaming on my todo
list there that isn't done yet. There I have 2 ethernet devices, 4 vlan
devices, 3 tap devices, and 3 bridges. I just haven't had an opportunity
to write and test the udev rules.

Unfortunately I had no opportunity this week to investigate the problem
any further. When I do I'll see whether I can pin down exactly what went
wrong with the older udev package and whether the new one fixes it. I
tried to simulate the problematic setup on another sarge/backports
machine with a bunch of dummy devices, but in that case everything
worked as expected.


Reply to: