[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: grub: amd64 missing

On 6/5/06, Norbert Tretkowski <norbert@tretkowski.de> wrote:
Okay, this was wrong, there are experimental buildds for amd64, and
they are already used on backports.org. Looks like the webinterface I
mentioned above is just outdated, so I can't see what's the problem
when building grub on amd64.

Grub won't build with gcc-3.3 on amd64 because it's essentially a
cross-compile.  So you have to tweak the Build-Depends to require
gcc-3.4 and tweak rules to use gcc-3.4 instead of the default gcc-3.3.
You also have to change the name of the ia32 compat libraries in

Huaqing Zheng
Beer and Code Wrangler at Large

Reply to: