[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: python2.3-pysqlite2 package problem


Keith Edmunds wrote:

> The python2.3-pysqlite2 package on backports seems to depend on Python
> 2.4 syntax (see below).
> [...]
> Unpacking python2.3-pysqlite2 (from
> .../python2.3-pysqlite2_2.2.0-0bpo1_i386.deb) ...
> Setting up python2.3-pysqlite2 (2.2.0-0bpo1) ...
> Compiling
> /usr/lib/python2.3/site-packages/FormEncode-0.5.1-py2.3.egg/formencode/formgen.py
> ...
>   File
> "/usr/lib/python2.3/site-packages/FormEncode-0.5.1-py2.3.egg/formencode/formgen.py",
> line 12
>     @dispatch.generic()
>     ^
> SyntaxError: invalid syntax
> [...]

I've just re-tested this on a clean system (ie, no python at all
installed prior to installation of python2.3-pysqlite2), and I cannot
reproduce this problem. The files causing the problems are not part of
python2.3-pysqlite2 (I'm a bit surprised, though, that they are being
tried to compile). Which packages do these files belong to?

Regards, Wolf

Sehnsüchtig grüßt der, der ich bin, den, der ich gerne sein möchte. (Sören 
Asbye Kierkegaard)

Reply to: