[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

KDE Upgrade from 3.5.0bpo to 3.5.1bbp


i tried to update my KDE like i above-mentioned. 
But there might be a problem with several packages. (e.g. kdelibs)

I wants to have a kde build against Xorg, because of the missing Composite 
Extension in XFree86.

When i try to do an apt-get upgrade / dist-upgrade a lot of new packages will
be ignored.

manfred@tuxbox:/etc/apt$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  kdebase kdessh kdeutils ksysguard
The following NEW packages will be installed:
  libmeanwhile1 libnss-mdns
The following packages have been kept back:
  akregator ark artsbuilder atlantik atlantikdesigner dcoprss juk kaboodle 
kaddressbook kaddressbook-plugins kalarm kamera kandy kappfinder
  karm kate kate-plugins kaudiocreator kcalc kcharselect kcoloredit kcontrol 
kcron kdat kdeaddons kdeaddons-kfile-plugins kdeadmin
  kdeadmin-kfile-plugins kdeartwork kdeartwork-style kdeartwork-theme-window 
kdebase-bin kdebase-kio-plugins kdegraphics
  kdegraphics-kfile-plugins kdelibs kdelibs-bin kdelibs4 kdelirc kdemultimedia 
kdemultimedia-kfile-plugins kdemultimedia-kio-plugins
  kdenetwork kdenetwork-filesharing kdenetwork-kfile-plugins kdepasswd kdepim 
kdepim-kfile-plugins kdepim-kio-plugins kdepim-kresources
  kdepim-wizards kdeprint kdesktop kdf kdict kdm kdvi kedit kfax kfaxview 
kfind kfloppy kgamma kget kghostview kgpg khelpcenter khexedit
  kicker kicker-applets kiconedit kitchensync kjots klaptopdaemon kleopatra 
klipper kmail kmailcvt kmenuedit kmid kmilo kmix kmrml
  knetworkconf knewsticker knode knotes kolourpaint konq-plugins konqueror 
konqueror-nsplugins konsole konsolekalendar kontact kooka kopete
  korganizer korn kpackage kpager kpdf kpersonalizer kpf kpilot kpovmodeler 
kppp krdc krec kregexpeditor krfb kruler kscd kscreensaver
  kscreensaver-xsavers ksig ksim ksirc ksmserver ksnapshot ksplash ksvg ksync 
ksysv ktimer ktip ktnef kuickshow kuser kview kviewshell
  kwalletmanager kwifimanager kwin libarts1-akode libarts1-xine libkcal2b 
libkcddb1 libkdegames1 libkdepim1a libkgantt0 libkleopatra1
  libkmime2 libkonq4 libkpimexchange1 libkpimidentities1 libkscan1 libksieve0 
libktnef1 librss1 networkstatus noatun noatun-plugins secpolicy
The following packages will be upgraded:
  arts kdeartwork-emoticons kdeartwork-misc kdeartwork-theme-icon kdebase-data 
kdelibs-data kdemultimedia-kappfinder-data kdewallpapers
  knewsticker-scripts ksysguardd libakode2 libarts1 libarts1-audiofile 
libarts1-mpeglib libartsc0 libcairo2 libindex0 libmimelib1a mpeglib
19 upgraded, 2 newly installed, 4 to remove and 154 not upgraded.
Need to get 31.9MB of archives.
After unpacking 1130kB disk space will be freed.
Do you want to continue [Y/n]? n

manfred@tuxbox:/etc/apt$ sudo apt-get install kdelibs
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  kdelibs: Depends: kdelibs4 (>= 4:3.5.2-0bbp1) but 4:3.5.0-2bpo2 is to be 
           Depends: kdelibs-bin (>= 4:3.5.2-0bbp1) but 4:3.5.0-2bpo2 is to be 
E: Broken packages

Reply to: