[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libsvn0-1.2.3dfsg1-2bpo1: missing perl swig bindings

Well, thanks for doing the extra digging, Sven. I installed the
libsvn-perl-core from sarge-backports, and all is well. I could've figured
this out myself with a little more diligence. My apologies to the fine
developers working on this backport package!

I would've expected apt to catch the dependency problem here. Perhaps I'm
wrong (again), but this suggests to me that the bug is in the stable
version of libsvn-core-perl, for depending on any libsvn0 >=1.1.4. Should
this be reported on bugs.debian.org?


<quote who="Sven Hoexter">
> On Wed, Mar 22, 2006 at 01:38:56PM -0500, GNU Dev wrote:
>>     < /usr/lib/libsvn_swig_perl-1.so.0
>>     < /usr/lib/libsvn_swig_perl-1.so.0.0.0
>>     < /usr/lib/libsvn_swig_py-1.so.0
>>     < /usr/lib/libsvn_swig_py-1.so.0.0.0
>>     38a35
>>     > /usr/share/doc/libsvn0/changelog.gz
>> When I said it should be an easy fix, to clarify, the pkg just needs to be
>> compiled with the right flags to ./configure, i.e. --with-perl
>> --with-python, or something like that. I can't imagine why this would
be difficult to accomplish. I'd do it myself if I was set up for
generating .debs and submitting them to backports.org.
> Ok I double checked that. You've just to install the right packages. The
libs moved into libsvn-core-perl, and python2.3-subversion.
> I even unpacked them by hand to be sure, yes they are their. So I guess
you just missed to install the right package from backports. Maybe
forget to pass aptitude the -t sarge-backports flag or something like
> Sven
> --
> If God passed a mic to me to speak
> I'd say stay in bed, world
> Sleep in peace
>    [The Cardigans - 03:45: No sleep]

Reply to: