[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#928612: u-boot-sunxi: Enable support for NanoPi NEO2

On Wed, May 08, 2019 at 06:28:28PM +0200, Domenico Andreoli wrote:
> On Tue, May 07, 2019 at 09:50:58AM -0700, Vagrant Cascadian wrote:
> > On 2019-05-07, Domenico Andreoli wrote:
> > >   Salsa MR #5 enables support for NanoPi NEO 2. I tested it with Buster
> > > RC1 installer, althought it resulted in a non-bootable system u-boot
> > > worked well enough.
> > 
> > Just for clarity, you're saying the non-bootability was unrelated to
> > u-boot, but u-boot was able to boot a kernel + initrd + dtb?


> Need to further investigate why u-boot cannot continue the boot. I
> don't know how a properly working arm64 world looks like and what's
> missing from my installation, if it's not just grub.
> I am not able to quickly hack a boot, the kernel is not just a familiar
> zImage and bootz is not even available. It must have something to do
> with all this UEFI order of things for which I need grub (or not?) ;)

Last minute update is that I run the Buster RC1 installer in rescue
mode and installed grub as removable device. Now u-boot loads grub
nicely and from there the system is booted flawlessly.

The normal method of installing grub fails because no UEFI is there to
handle the configuration of the new entry:

Installing for arm64-efi platform.
grub-install: warning: Cannot set EFI variable Boot0000.
grub-install: warning: efivarfs_set_variable: writing to fd 6 failed: Input/output error.
grub-install: warning: efivarfs_set_variable: failed to unlink /sys/firmware/efi/efivars/Boot0000-8be4df61-93ca-11d2-aa0d-00e098032b8c: Invalid argument.
grub-install: warning: _efi_set_variable_mode: ops->set_variable() failed: Input/output error.
grub-install: error: failed to register the EFI boot entry: Input/output error.


3B10 0CA1 8674 ACBA B4FE  FCD2 CE5B CF17 9960 DE13

Reply to: