[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lacie network space v2: upgrade from wheezy to jessie

El 22/9/15 a les 11:41, Simon Guinot ha escrit:
On Thu, Sep 17, 2015 at 01:24:32PM +0200, Luca Olivetti wrote:
El 17/09/15 a les 10:37, Simon Guinot ha escrit:
On Wed, Sep 16, 2015 at 08:11:10PM -0400, Martin Michlmayr wrote:
* Luca Olivetti <luca@ventoso.org> [2015-09-13 19:32]:
apologies if this is the wrong list.
I'm currently running debian wheezy on a lacie network space v2.
I'd like to dist-upgrade it to jessie. Is it reasonably safe to do so?
I can get access to a serial console, but I'd avoid it (IIRC the pins are
difficult to reach).

I copied Simon Guinot who may know.

Hi Luca,

I have never tried this but I believe it is safe. Once done, just make
sure that your bootloader is still able to reach the Linux kernel.
I don't think there is something else to check.

Well, I performed a dist-upgrade from the previous version to wheezy
and it did work, but with the changes in dtb support I'm worried
that the kernel won't have the correct dtb appended (in other words,
I'm worried that kernel-image will be upgraded before flash-kernel).
Is there somebody running wheezy (and a current kernel with dtb
support) on a network space 2?
You know, this ns2 is my mail,dns and dhcp server (as well as shared
storage), so I need the upgrade to work ;-)

Sorry. Since I have never tried then I can't ensure it will work.
But I am confident that we should be able to recover from any kind
of situations.

If you need some help, you will be welcome on the IRC channel or the ML
of the lacie-nas.org project.


2 and a half year later I finally bit the bullet and performed the upgrade (first to jessie and then to stretch).
Apart from a couple of minor issues[*] it went well.

Now I'm currently rebuilding mosquitto from testing (I'm using a locally compiled 1.5.3 while stretch is still on 1.4.x) and I previously built a local package of dspam since it's been dropped from debian and there's no real substitute for low resources machines (though the old version still worked after the update).

[*] upgrading to jessie it seems it tried to generate the initramfs or uImage before unpacking the kernel, so apt-get stopped, panic ensued but an "apt-get -f install" fixed it and I could repeat an "apt-get dist-upgrade". Also for some reason cyrus-imapd wasn't enabled, again "systemctl enable cyrus-imapd" fixed it. I also had to adapt a couple of configuration files but that was in the release notes, so no problem there.


Reply to: